dev-php/pecl-oauth: Revision bump to drop php 5.4 and 5.5
authorBrian Evans <grknight@gentoo.org>
Thu, 1 Dec 2016 15:45:16 +0000 (10:45 -0500)
committerBrian Evans <grknight@gentoo.org>
Thu, 1 Dec 2016 15:46:54 +0000 (10:46 -0500)
Package-Manager: portage-2.3.2

dev-php/pecl-oauth/pecl-oauth-1.2.3-r4.ebuild [new file with mode: 0644]

diff --git a/dev-php/pecl-oauth/pecl-oauth-1.2.3-r4.ebuild b/dev-php/pecl-oauth/pecl-oauth-1.2.3-r4.ebuild
new file mode 100644 (file)
index 0000000..7d9bd3c
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+PHP_EXT_NAME="oauth"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php5-6"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="OAuth is an authorization protocol built on top of HTTP"
+LICENSE="BSD"
+SLOT="0"
+IUSE="examples"
+
+for target in ${USE_PHP}; do
+       slot=${target/php}
+       slot=${slot/-/.}
+       PHPUSEDEPEND="${PHPUSEDEPEND}
+       php_targets_${target}? ( dev-lang/php:${slot}[hash] )"
+done
+
+DEPEND="${PHPUSEDEPEND}"
+RDEPEND="${DEPEND}"