Fix building with gcc-2.
authorMike Frysinger <vapier@gentoo.org>
Fri, 29 Dec 2006 22:36:21 +0000 (22:36 +0000)
committerMike Frysinger <vapier@gentoo.org>
Fri, 29 Dec 2006 22:36:21 +0000 (22:36 +0000)
Package-Manager: portage-2.1.2_rc4-r1

sys-apps/busybox/ChangeLog
sys-apps/busybox/busybox-1.2.2.1.ebuild
sys-apps/busybox/files/1.2.0/gcc2.patch [new file with mode: 0644]

index 702bb5f885ea379dfb134ba6265f51fc624aef3b..e7484314cc5381755f1a5ab3d68eb29f5616b787 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for sys-apps/busybox
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.116 2006/12/01 22:21:36 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.117 2006/12/29 22:36:21 vapier Exp $
+
+  29 Dec 2006; Mike Frysinger <vapier@gentoo.org> +files/1.2.0/gcc2.patch,
+  busybox-1.2.2.1.ebuild:
+  Fix building with gcc-2.
 
   01 Dec 2006; Markus Rothe <corsair@gentoo.org> busybox-1.2.2.1.ebuild:
   Stable on ppc64
index 15781542f73b6572bb9ca75fbfda07e6499f2e3a..caa91bc04cb38fd7c231777c26dc134d895a253e 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.2.2.1.ebuild,v 1.2 2006/12/01 22:21:36 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.2.2.1.ebuild,v 1.3 2006/12/29 22:36:21 vapier Exp $
 
 inherit eutils flag-o-matic
 
@@ -101,6 +101,7 @@ src_unpack() {
 
        # patches go here!
        epatch "${FILESDIR}"/1.2.0/bb.patch
+       epatch "${FILESDIR}"/1.2.0/gcc2.patch
 
        # check for a busybox config before making one of our own.
        # if one exist lets return and use it.
diff --git a/sys-apps/busybox/files/1.2.0/gcc2.patch b/sys-apps/busybox/files/1.2.0/gcc2.patch
new file mode 100644 (file)
index 0000000..37b223f
--- /dev/null
@@ -0,0 +1,19 @@
+--- networking/zcip.c
++++ networking/zcip.c
+@@ -299,13 +301,13 @@ int zcip_main(int argc, char *argv[])
+               struct timeval tv1;
+               struct arp_packet p;
++              int source_ip_conflict = 0;
++              int target_ip_conflict = 0;
++
+               fds[0].fd = fd;
+               fds[0].events = POLLIN;
+               fds[0].revents = 0;
+-              int source_ip_conflict = 0;
+-              int target_ip_conflict = 0;
+-
+               // poll, being ready to adjust current timeout
+               if (!timeout) {
+                       timeout = ms_rdelay(PROBE_WAIT);