sci-libs/libsvm: Drop old
authorJustin Lecher <jlec@gentoo.org>
Sat, 25 Feb 2017 20:45:17 +0000 (20:45 +0000)
committerJustin Lecher <jlec@gentoo.org>
Sat, 25 Feb 2017 20:56:26 +0000 (20:56 +0000)
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
sci-libs/libsvm/Manifest
sci-libs/libsvm/libsvm-3.17-r1.ebuild [deleted file]
sci-libs/libsvm/libsvm-3.17-r3.ebuild [deleted file]

index 428fc5c79eef66a2e591039cedead085531f758e..9ef4802893d4677b2996b0dd2723a3d8ac9c29c0 100644 (file)
@@ -1,2 +1 @@
-DIST libsvm-3.17.tar.gz 607892 SHA256 46a4750d3506e6ccd8adf7e3e1f482d86ce9c5368f9c78e19c7923edf0067a12 SHA512 43f3e7cbee37b583cd65041465ef620ab7b3a24ad3f0e70cc2f41efea847e8c1c7319a92b53262bc5f721a46c0cfb4d51102d2e29c93b6ccae03ecf006e53d2d WHIRLPOOL 9518e2aeb5d2f0ac0945fa193edfaf7ba022729cc9ea91e5a773fed638fdcaef4d4bea0f284f1698571b570f5543afc8987ec81a54637d537c709b09474f6fbc
 DIST libsvm-3.21.tar.gz 847291 SHA256 519e0bdc0e31ab8246e9035e7ca91f794c16084f80abe4dffe776261d23c772f SHA512 697a7505100e48746a87e3e4ab025524fa581856320da3a187ac501138ce0a5bc7885ff37454ae5e75d6b0eab94e368b6bcd36601ad18db3b2fb35d2f360520a WHIRLPOOL d0ef916d37a3cc24680b6eba62d29caca9c36fa41ae8f22445137e044c7cf66a754c3d12670697fce174b388fe30906b2a4dc437cb38e7c6f1dd8dde85f51b84
diff --git a/sci-libs/libsvm/libsvm-3.17-r1.ebuild b/sci-libs/libsvm/libsvm-3.17-r1.ebuild
deleted file mode 100644 (file)
index d264cc9..0000000
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-inherit eutils java-pkg-opt-2 python-r1 flag-o-matic toolchain-funcs
-
-DESCRIPTION="Library for Support Vector Machines"
-HOMEPAGE="http://www.csie.ntu.edu.tw/~cjlin/libsvm/"
-SRC_URI="http://www.csie.ntu.edu.tw/~cjlin/libsvm/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="java openmp python tools"
-
-DEPEND="java? ( >=virtual/jdk-1.4 )"
-RDEPEND="
-       java? ( >=virtual/jre-1.4 )
-       tools? ( sci-visualization/gnuplot )"
-
-pkg_setup() {
-       if use openmp; then
-               if [[ $(tc-getCC)$ == *gcc* ]] && ! tc-has-openmp; then
-                       ewarn "You are using gcc but without OpenMP capabilities"
-                       die "Need an OpenMP capable compiler"
-               else
-                       append-ldflags -fopenmp
-                       append-flags -fopenmp
-               fi
-               append-flags -DOPENMP
-       fi
-}
-
-src_prepare() {
-       epatch \
-               "${FILESDIR}"/3.11-openmp.patch \
-               "${FILESDIR}"/3.14-makefile.patch
-       sed -i -e "s@\.\./@${EPREFIX}/usr/bin/@g" tools/*.py \
-               || die "Failed to fix paths in python files"
-
-       if use java; then
-               local JAVAC_FLAGS="$(java-pkg_javac-args)"
-               sed -i \
-                       -e "s/JAVAC_FLAGS =/JAVAC_FLAGS=${JAVAC_FLAGS}/g" \
-                       java/Makefile || die "Failed to fix java makefile"
-       fi
-       tc-export CXX CC
-}
-
-src_compile() {
-       default
-       use java && emake -C java
-}
-
-src_install() {
-       dobin svm-train svm-predict svm-scale
-       dolib.so *.so*
-       insinto /usr/include
-       doins svm.h
-       dohtml FAQ.html
-       dodoc README
-
-       if use tools; then
-               local t
-               for t in tools/*.py; do
-                       newbin ${t} svm-$(basename ${t} .py)
-               done
-               newdoc tools/README README.tools
-               insinto /usr/share/doc/${PF}
-               doins heart_scale
-               doins -r svm-toy
-       fi
-
-       if use python ; then
-               installation() {
-                       touch python/__init__.py || die
-                       python_moduleinto libsvm
-                       python_domodule python/*.py
-               }
-               python_foreach_impl installation
-               newdoc python/README README.python
-       fi
-
-       if use java; then
-               java-pkg_dojar java/libsvm.jar
-               dohtml java/test_applet.html
-       fi
-}
diff --git a/sci-libs/libsvm/libsvm-3.17-r3.ebuild b/sci-libs/libsvm/libsvm-3.17-r3.ebuild
deleted file mode 100644 (file)
index 9e50444..0000000
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-inherit flag-o-matic java-pkg-opt-2 python-r1 toolchain-funcs
-
-DESCRIPTION="Library for Support Vector Machines"
-HOMEPAGE="http://www.csie.ntu.edu.tw/~cjlin/libsvm/"
-SRC_URI="http://www.csie.ntu.edu.tw/~cjlin/libsvm/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="java openmp python tools"
-
-DEPEND="java? ( >=virtual/jdk-1.4 )"
-RDEPEND="
-       java? ( >=virtual/jre-1.4 )
-       tools? ( sci-visualization/gnuplot )"
-
-PATCHES=(
-       "${FILESDIR}/3.11-openmp.patch"
-       "${FILESDIR}/3.14-makefile.patch"
-)
-
-pkg_setup() {
-       if use openmp; then
-               if ! tc-has-openmp; then
-                       ewarn "OpenMP is not supported by your currently selected compiler"
-
-                       if tc-is-clang; then
-                               ewarn "OpenMP support in sys-devel/clang is provided by sys-libs/libomp,"
-                               ewarn "which you will need to build ${CATEGORY}/${PN} for USE=\"openmp\""
-                       fi
-
-                       die "need openmp capable compiler"
-               fi
-
-               append-cflags -fopenmp
-               append-cxxflags -fopenmp
-               append-cppflags -DOPENMP
-       fi
-}
-
-src_prepare() {
-       default
-
-       sed -i -e "s@\.\./@${EPREFIX}/usr/bin/@g" tools/*.py \
-               || die "Failed to fix paths in python files"
-       sed -i -e "s|./grid.py|${EPREFIX}/usr/bin/svm-grid|g" tools/*.py \
-               || die "Failed to fix paths for svm-grid"
-       sed -i -e 's/grid.py/svm-grid/g' tools/grid.py \
-               || die "Failed to rename grid.py to svm-grid"
-
-       if use java; then
-               local JAVAC_FLAGS="$(java-pkg_javac-args)"
-               sed -i \
-                       -e "s/JAVAC_FLAGS =/JAVAC_FLAGS=${JAVAC_FLAGS}/g" \
-                       java/Makefile || die "Failed to fix java makefile"
-       fi
-       tc-export CXX CC
-}
-
-src_compile() {
-       default
-       use java && emake -C java
-}
-
-src_install() {
-       dobin svm-train svm-predict svm-scale
-       dolib.so *.so*
-       insinto /usr/include
-       doins svm.h
-
-       dodoc README
-
-       if use tools; then
-               local t
-               for t in tools/*.py; do
-                       python_foreach_impl python_newscript ${t} svm-$(basename ${t} .py)
-               done
-
-               newdoc tools/README README.tools
-
-               insinto /usr/share/doc/${PF}/examples
-               doins heart_scale
-               doins -r svm-toy
-       fi
-
-       if use python ; then
-               installation() {
-                       touch python/__init__.py || die
-                       python_moduleinto libsvm
-                       python_domodule python/*.py
-               }
-               python_foreach_impl installation
-               newdoc python/README README.python
-       fi
-
-       docinto html
-       if use java; then
-               java-pkg_dojar java/libsvm.jar
-               dodoc java/test_applet.html
-       fi
-
-       dodoc FAQ.html
-}