sys-devel/llvm: Enable Python 3 in -9999
authorMichał Górny <mgorny@gentoo.org>
Tue, 11 Jun 2019 17:09:20 +0000 (19:09 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 11 Jun 2019 17:12:25 +0000 (19:12 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-devel/llvm/llvm-9999.ebuild

index fe059751a9f6cf0fc82a19f818f1ab1f46d5d8d5..f194df950517a81840f8b4846eb0bf7c131930f5 100644 (file)
@@ -6,7 +6,7 @@ EAPI=6
 : ${CMAKE_MAKEFILE_GENERATOR:=ninja}
 # (needed due to CMAKE_BUILD_TYPE != Gentoo)
 CMAKE_MIN_VERSION=3.7.0-r1
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
 
 inherit cmake-utils eapi7-ver flag-o-matic git-r3 multilib-minimal \
        multiprocessing pax-utils python-any-r1 toolchain-funcs
@@ -288,7 +288,7 @@ multilib_src_install_all() {
 pkg_postinst() {
        elog "You can find additional opt-viewer utility scripts in:"
        elog "  ${EROOT%/}/usr/lib/llvm/${SLOT}/share/opt-viewer"
-       elog "To use these scripts, you will need Python 2.7 along with the following"
+       elog "To use these scripts, you will need Python along with the following"
        elog "packages:"
        elog "  dev-python/pygments (for opt-viewer)"
        elog "  dev-python/pyyaml (for all of them)"