dev-ruby/facter: 3.13.3 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 16 Jul 2019 15:06:15 +0000 (10:06 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 16 Jul 2019 15:06:28 +0000 (10:06 -0500)
Package-Manager: Portage-2.3.66, Repoman-2.3.16
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-ruby/facter/Manifest
dev-ruby/facter/facter-3.13.3.ebuild [new file with mode: 0644]

index 202f831e580c40ca832cef3debf4822418808d87..5ea2e4c745dbf1136a4cb0fa4d832778115de757 100644 (file)
@@ -1,3 +1,4 @@
 DIST facter-3.13.2.tar.gz 392065 BLAKE2B ae06a1a44de25f55b2eb84483a7abc70433b9437a00724f239a908846148f20bdb3e208d10256e6ddeb7d609ee9eb1c572e14dad84d8640fee147c34cb1bf184 SHA512 c7d1d0958720e0884b06eccf6d7fca64d2c8462c1747bbfbfe5df957ad009c3e930fe5eee80d42c985ea9f59e2b8b7d0a34a194a7e1c713a043bbee9a3b89df3
+DIST facter-3.13.3.tar.gz 393406 BLAKE2B 2a428fc43a46024233f2924a759a52bcbf55655cc430add9cbe4958ae36c581c2bbd05069279e129fea2f29afd8cf3a3a6a522b728d14214192253e0010b05c3 SHA512 26b1788aae0ffbc7ad9365f03486be5a3a6c27c4b06542aad68eceb34de90de53128d2abcb47fa6cbaeee082b1c1b86739d70619c7263b8797e49a0ed7f6c652
 DIST facter-3.14.1.tar.gz 393548 BLAKE2B a3f61df9a7a302948fa8579c451b5cdb973a3e8b92109582b1a6046c68e5212b675f9310012409194f933574d004a7a3fbed1dc0e20576a2ee759feadeac54ee SHA512 b3f4cbaffb2c70423fd9d5eca7afdee35f92f3a3445fb78996258471a3dc3881b1797bed5ee90aa66b62b0e9d1b979dbc05b6e169499d4f1a9e61f002118476d
 DIST facter-3.9.2.tar.gz 380883 BLAKE2B d2804664e0499715230e5696c5a9ebae933f5b43dfb37154251d47763c2c7f78cfa8d1413dd836e5a0c76ed67300d066fa5bb390f17f85cd4cb7a444eaf0d133 SHA512 bc040826311bbff40f5a151ade315d9d47ef1e0f3faa570805e48ca55405265e66308230118b9cd59f701ecd76a7b0fd4d9200dd4ace838521223a162b105374
diff --git a/dev-ruby/facter/facter-3.13.3.ebuild b/dev-ruby/facter/facter-3.13.3.ebuild
new file mode 100644 (file)
index 0000000..4c7110c
--- /dev/null
@@ -0,0 +1,112 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+# git-r3 goes after ruby-ng so that it overrides src_unpack properly
+inherit cmake-utils eutils multilib ruby-ng
+
+DESCRIPTION="A cross-platform ruby library for retrieving facts from operating systems"
+HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="debug test"
+if [[ ${PV} == 9999 ]] ; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/puppetlabs/facter.git"
+       EGIT_BRANCH="master"
+else
+       [[ "${PV}" = *_rc* ]] || \
+       KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+       SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+BDEPEND="
+       >=sys-devel/gcc-4.8:*
+       dev-cpp/cpp-hocon"
+COMMON_DEPEND="
+       >=dev-libs/leatherman-1.0.0:=
+       dev-libs/openssl:0=
+       sys-apps/util-linux
+       app-emulation/virt-what
+       net-misc/curl
+       >=dev-libs/boost-1.54:=[nls]
+       <dev-libs/boost-1.70.0
+       >=dev-cpp/yaml-cpp-0.5.1
+       !<app-admin/puppet-4.0.0"
+
+ruby_add_bdepend "test? ( dev-ruby/rake dev-ruby/rspec:2 dev-ruby/mocha:0.14 )"
+
+RDEPEND="${COMMON_DEPEND}"
+DEPEND="${BDEPEND}
+       ${COMMON_DEPEND}"
+
+# restore ${S} and override all phases exported by ruby-ng.eclass
+S="${WORKDIR}/${P}"
+
+pkg_setup() {
+       ruby-ng_pkg_setup
+}
+
+src_unpack() {
+       default
+
+       if [[ ${PV} == 9999 ]] ; then
+               git-r3_src_unpack
+       fi
+}
+
+src_prepare() {
+       # be explicit about the version of rspec we test with
+       sed -i -e '/libfacter.*specs/ s/rspec/rspec-2/' \
+               CMakeLists.txt || die
+       # be more lenient for software versions for tests
+       sed -i -e '/rake/ s/~> 10.1.0/>= 10/' \
+               -e '/rspec/ s/2.11.0/2.11/' \
+               -e '/mocha/ s/0.10.5/0.14.0/' lib/Gemfile || die
+       # patches
+       default
+       cmake-utils_src_prepare
+}
+
+each_ruby_configure() {
+       # hack for correct calculation of relative path from facter.rb to
+       # libfacter.so
+       my_ruby_sitelibdir=$(ruby_rbconfig_value 'sitelibdir')
+}
+
+src_configure() {
+       ruby-ng_src_configure
+
+       local mycmakeargs=(
+               -DCMAKE_VERBOSE_MAKEFILE=ON
+               -DRUBY_LIB_INSTALL=${my_ruby_sitelibdir}
+               -DBLKID_LIBRARYDIR="${EPREFIX}/$(get_libdir)"
+       )
+       if use debug; then
+               mycmakeargs+=(
+                 -DCMAKE_BUILD_TYPE=Debug
+               )
+       fi
+       cmake-utils_src_configure
+}
+
+src_compile() {
+       addpredict /proc/self/oom_score_adj
+       cmake-utils_src_compile
+}
+
+src_test() {
+       cmake-utils_src_test
+}
+
+each_ruby_install() {
+       doruby "${BUILD_DIR}"/lib/facter.rb
+}
+
+src_install() {
+       cmake-utils_src_install
+       ruby-ng_src_install
+}