dev-perl/Exporter-Tiny: Bump to 0.44.0
authorKent Fredric <kentnl@gentoo.org>
Thu, 23 Feb 2017 01:46:35 +0000 (14:46 +1300)
committerKent Fredric <kentnl@gentoo.org>
Thu, 23 Feb 2017 01:46:57 +0000 (14:46 +1300)
- EAPI6
- Tests enabled
- Add USE="examples"

Upstream:
- Documentation overhaul
- Supports programmatically renaming functions by passing a CODE
  ref to { -as => CODE } for computing derived name of $_[0]

Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-perl/Exporter-Tiny/Exporter-Tiny-0.44.0.ebuild [new file with mode: 0644]
dev-perl/Exporter-Tiny/Manifest
dev-perl/Exporter-Tiny/metadata.xml

diff --git a/dev-perl/Exporter-Tiny/Exporter-Tiny-0.44.0.ebuild b/dev-perl/Exporter-Tiny/Exporter-Tiny-0.44.0.ebuild
new file mode 100644 (file)
index 0000000..7856b1e
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=TOBYINK
+DIST_VERSION=0.044
+DIST_EXAMPLES=( "examples/*" )
+inherit perl-module
+
+DESCRIPTION="An exporter with the features of Sub::Exporter but only core dependencies"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+       >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+       test? (
+               >=virtual/perl-Test-Simple-0.470.0
+       )
+"
index a6d9a162039a2b077aeefaeaf4244ad2944081f8..c80bfb979b786deef75e01147d4ae71111479703 100644 (file)
@@ -1 +1,2 @@
 DIST Exporter-Tiny-0.042.tar.gz 32173 SHA256 8f1622c5ebbfbcd519ead81df7917e48cb16cc527b1c46737b0459c3908a023f SHA512 b69b722842b4a907fa434a1a798df6f983bae74d7b82e925a1db684cb166f2ef02a72cce176173af035321dc27ad35b49e1fb1ee57c0e2ca6596d84da140c06f WHIRLPOOL 9b43e4b2ca3d0ce6dfc4333914e340e10da032fab8535fb208bf2a4e79e7d4e26b46b09cbf178bdf31eba3584169316fe44ec6ce5c14405d4648d91e60a46f61
+DIST Exporter-Tiny-0.044.tar.gz 29636 SHA256 eda868cc2da094b685ceace4245b83de11f439feb98e0ec8246cfbb9109c88ab SHA512 49f8df450c1e21b56df3ef0f15ef138f21429a2a4c3c0e8809b25c57dc42ae4d28e3db125676ca5d293517d36a81b41fcfe2b3f4a4d37530b5de5f92bd05d03a WHIRLPOOL 19c8697acefb28162e2ea9387ed49eb11d7165e316cf4b5e485b59b5f85cbed34602dd26b2aae2081aa6d3fd6b8e4d6518c1997c63ef2f5ef088545b24b1ab8b
index 2b9a936fc0a1933802b5db1fa4b28a53939f2a4e..0dac48b7a5028bb62aabf78cafc57c023a4eb568 100644 (file)
@@ -5,4 +5,10 @@
     <email>perl@gentoo.org</email>
     <name>Gentoo Perl Project</name>
   </maintainer>
+  <upstream>
+    <remote-id type="github">tobyink/p5-exporter-tiny</remote-id>
+    <remote-id type="cpan">Exporter-Tiny</remote-id>
+    <remote-id type="cpan-module">Exporter::Shiny</remote-id>
+    <remote-id type="cpan-module">Exporter::Tiny</remote-id>
+  </upstream>
 </pkgmetadata>