dev-python/ws4py: Remove Python 2
authorMichał Górny <mgorny@gentoo.org>
Sun, 26 Jan 2020 17:01:24 +0000 (18:01 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 26 Jan 2020 17:11:38 +0000 (18:11 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/ws4py/ws4py-0.3.4-r1.ebuild
dev-python/ws4py/ws4py-0.5.1.ebuild
dev-python/ws4py/ws4py-9999.ebuild

index 8637c49058411c001cfc087075b26b26b8b8c80d..d6697eff1d247d83c5bdf5f5b0bac8e323a8cdc7 100644 (file)
@@ -7,7 +7,7 @@
 # pypy is viable but better with a cutdown set of deps
 
 EAPI=5
-PYTHON_COMPAT=( python{2_7,3_6} )
+PYTHON_COMPAT=( python3_6 )
 PYTHON_REQ_USE="threads?"
 
 inherit distutils-r1
@@ -30,7 +30,6 @@ RESTRICT="!test? ( test )"
 # doc build requires sphinxcontrib ext packages absent from portage
 
 RDEPEND=">=dev-python/greenlet-0.4.1[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep 'dev-python/gevent[${PYTHON_USEDEP}]' python2_7)
                >=dev-python/cython-0.19.1[${PYTHON_USEDEP}]
                client? ( >=www-servers/tornado-3.1[${PYTHON_USEDEP}] )
                server? ( <dev-python/cherrypy-9[${PYTHON_USEDEP}] )"
index 34de8e37ab89cf5412f3a228a01331e9f4f4c710..38507310ab2a7d156d09b356b6990c9b39589121 100644 (file)
@@ -7,7 +7,7 @@
 # pypy is viable but better with a cutdown set of deps
 
 EAPI=6
-PYTHON_COMPAT=( python{2_7,3_6} )
+PYTHON_COMPAT=( python3_6 )
 PYTHON_REQ_USE="threads?"
 
 inherit distutils-r1
@@ -30,7 +30,6 @@ RESTRICT="!test? ( test )"
 # doc build requires sphinxcontrib ext packages absent from portage
 
 RDEPEND=">=dev-python/greenlet-0.4.1[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep 'dev-python/gevent[${PYTHON_USEDEP}]' python2_7)
                >=dev-python/cython-0.19.1[${PYTHON_USEDEP}]
                client? ( >=www-servers/tornado-3.1[${PYTHON_USEDEP}] )
                server? ( >=dev-python/cherrypy-3.2.4[${PYTHON_USEDEP}] )"
index 5c1543f24678aa437bbcce691f99ae1954919a1a..461f735ab784ddb81e1a1a9105fb4ba1efe40176 100644 (file)
@@ -7,7 +7,7 @@
 # pypy is viable but better with a cutdown set of deps
 
 EAPI=6
-PYTHON_COMPAT=( python{2_7,3_6} )
+PYTHON_COMPAT=( python3_6 )
 PYTHON_REQ_USE="threads?"
 
 inherit distutils-r1
@@ -30,7 +30,6 @@ RESTRICT="!test? ( test )"
 # doc build requires sphinxcontrib ext packages absent from portage
 
 RDEPEND=">=dev-python/greenlet-0.4.1[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep 'dev-python/gevent[${PYTHON_USEDEP}]' python2_7)
                >=dev-python/cython-0.19.1[${PYTHON_USEDEP}]
                client? ( >=www-servers/tornado-3.1[${PYTHON_USEDEP}] )
                server? ( >=dev-python/cherrypy-3.2.4[${PYTHON_USEDEP}] )"