net-fs/davfs2: fix building with gcc 10 #706356
authorGöktürk Yüksek <gokturk@gentoo.org>
Mon, 27 Jan 2020 23:44:56 +0000 (18:44 -0500)
committerGöktürk Yüksek <gokturk@gentoo.org>
Tue, 28 Jan 2020 02:31:16 +0000 (21:31 -0500)
Closes: https://bugs.gentoo.org/706356
Bug: http://savannah.nongnu.org/support/index.php?110186
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
net-fs/davfs2/davfs2-1.5.5.ebuild
net-fs/davfs2/files/davfs2-1.5.5-gcc-10.patch [new file with mode: 0644]

index 3ef5dd25f0037145e4c4b7428a1aa3bbf1831a4e..e90fe83a11dd7845f69a220beb81c5061ac31323 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -33,6 +33,9 @@ src_prepare() {
        sed -e '/^manual[58]_DATA/ s/\.gz//g' \
                -i "${S}"/man/Makefile.in || die
 
+       # Bug: https://bugs.gentoo.org/706356
+       eapply "${FILESDIR}"/${PN}-1.5.5-gcc-10.patch
+
        default
 }
 
diff --git a/net-fs/davfs2/files/davfs2-1.5.5-gcc-10.patch b/net-fs/davfs2/files/davfs2-1.5.5-gcc-10.patch
new file mode 100644 (file)
index 0000000..56b0bab
--- /dev/null
@@ -0,0 +1,18 @@
+Handle building with '-fno-common' for gcc 10.
+See: https://bugs.gentoo.org/706356
+
+
+--- a/src/dav_coda.c
++++ b/src/dav_coda.c
+@@ -99,3 +99,3 @@ static size_t alignment;
+ /* Send debug messages to syslog if != 0. */
+-int debug;
++static int debug;
+--- a/src/dav_fuse.c
++++ b/src/dav_fuse.c
+@@ -86,3 +86,3 @@ static uint64_t root;
+ /* Send debug messages to syslog if != 0. */
+-int debug;
++static int debug;