media-video/mplayer: added vcd and yuv4mpeg USE flags, bug #574806
authorhkgz <hkgz@localhost.localdomain>
Thu, 3 Mar 2016 13:14:47 +0000 (13:14 +0000)
committerhkgz <hkgz@localhost.localdomain>
Thu, 3 Mar 2016 13:14:47 +0000 (15:14 +0200)
media-video/mplayer/metadata.xml
media-video/mplayer/mplayer-1.2.1.ebuild
media-video/mplayer/mplayer-1.3.0.ebuild
media-video/mplayer/mplayer-9999.ebuild

index c6d7f2f154ed9b114bcf72e5b49ad533d49c5f08..0bde38230254746291577289d0de4873b284006e 100644 (file)
     <flag name="toolame">Enable toolame MPEG-2 encoding</flag>
     <flag name="tremor">Enable internal support for Vorbis</flag>
     <flag name="twolame">Enable twolame MPEG-2 encoding</flag>
+    <flag name="vcd">Enables VCD support</flag>
     <flag name="vidix">Support for vidix video output</flag>
     <flag name="xanim">Enables support for xanim based codecs</flag>
     <flag name="xvmc">Enables X-Video Motion Compensation support</flag>
+    <flag name="yuv4mpeg">Enables yuv4mpeg video output</flag>
     <flag name="zoran">Enables ZR360[56]7/ZR36060 video output</flag>
   </use>
 </pkgmetadata>
index e524a124d3e75a02a3228d837460a6dd53ae658c..c2a89edb32faf95004b5b9e48601bb19f27103bf 100644 (file)
@@ -17,8 +17,8 @@ ftp gif ggi gsm +iconv ipv6 jack joystick jpeg jpeg2k kernel_linux ladspa
 +libass libcaca libmpeg2 lirc live lzo mad md5sum +cpu_flags_x86_mmx cpu_flags_x86_mmxext mng mp3 nas
 +network nut openal opengl +osdmenu oss png pnm pulseaudio pvr
 radio rar rtc rtmp samba selinux +shm sdl speex cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_ssse3
-tga theora tremor +truetype toolame twolame +unicode v4l vdpau vidix
-vorbis +X x264 xanim xinerama +xscreensaver +xv xvid xvmc zoran"
+tga theora tremor +truetype toolame twolame +unicode v4l vcd vdpau vidix
+vorbis +X x264 xanim xinerama +xscreensaver +xv xvid xvmc yuv4mpeg zoran"
 
 VIDEO_CARDS="s3virge mga tdfx"
 for x in ${VIDEO_CARDS}; do
@@ -299,7 +299,7 @@ src_configure() {
                $(use_enable network networking)
                $(use_enable joystick)
        "
-       uses="bl bluray enca ftp rtc" # nemesi <- not working with in-tree ebuild
+       uses="bl bluray enca ftp rtc vcd" # nemesi <- not working with in-tree ebuild
        myconf+=" --disable-nemesi" # nemesi automagic disable
        for i in ${uses}; do
                use ${i} || myconf+=" --disable-${i}"
@@ -422,7 +422,7 @@ src_configure() {
        ################
        # Video Output #
        ################
-       uses="directfb md5sum sdl"
+       uses="directfb md5sum sdl yuv4mpeg"
        for i in ${uses}; do
                use ${i} || myconf+=" --disable-${i}"
        done
index 8a5b4011be4d784e70c26ded6928772672729570..c5eb0851e7a414f260f48cbadd5c3b7145db89dc 100644 (file)
@@ -17,8 +17,8 @@ ftp gif ggi gsm +iconv ipv6 jack joystick jpeg jpeg2k kernel_linux ladspa
 +libass libcaca libmpeg2 lirc live lzo mad md5sum +cpu_flags_x86_mmx cpu_flags_x86_mmxext mng mp3 nas
 +network nut openal opengl +osdmenu oss png pnm pulseaudio pvr
 radio rar rtc rtmp samba selinux +shm sdl speex cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_ssse3
-tga theora tremor +truetype toolame twolame +unicode v4l vdpau vidix
-vorbis +X x264 xanim xinerama +xscreensaver +xv xvid xvmc zoran"
+tga theora tremor +truetype toolame twolame +unicode v4l vcd vdpau vidix
+vorbis +X x264 xanim xinerama +xscreensaver +xv xvid xvmc yuv4mpeg zoran"
 
 VIDEO_CARDS="s3virge mga tdfx"
 for x in ${VIDEO_CARDS}; do
@@ -293,7 +293,7 @@ src_configure() {
                $(use_enable network networking)
                $(use_enable joystick)
        "
-       uses="bl bluray enca ftp rtc" # nemesi <- not working with in-tree ebuild
+       uses="bl bluray enca ftp rtc vcd" # nemesi <- not working with in-tree ebuild
        myconf+=" --disable-nemesi" # nemesi automagic disable
        for i in ${uses}; do
                use ${i} || myconf+=" --disable-${i}"
@@ -416,7 +416,7 @@ src_configure() {
        ################
        # Video Output #
        ################
-       uses="directfb md5sum sdl"
+       uses="directfb md5sum sdl yuv4mpeg"
        for i in ${uses}; do
                use ${i} || myconf+=" --disable-${i}"
        done
index 586f70ab309c060ed1eabdb1e62de2e78ab16ff2..1e3a45bfd0ddda5db52c56411bc8b9081d2858b1 100644 (file)
@@ -17,8 +17,8 @@ ftp gif ggi gsm +iconv ipv6 jack joystick jpeg jpeg2k kernel_linux ladspa
 +libass libcaca libmpeg2 lirc live lzo mad md5sum +cpu_flags_x86_mmx cpu_flags_x86_mmxext mng mp3 nas
 +network nut openal opengl +osdmenu oss png pnm pulseaudio pvr
 radio rar rtc rtmp samba selinux +shm sdl speex cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_ssse3
-tga theora tremor +truetype toolame twolame +unicode v4l vdpau vidix
-vorbis +X x264 xanim xinerama +xscreensaver +xv xvid xvmc zoran"
+tga theora tremor +truetype toolame twolame +unicode v4l vcd vdpau vidix
+vorbis +X x264 xanim xinerama +xscreensaver +xv xvid xvmc yuv4mpeg zoran"
 
 VIDEO_CARDS="s3virge mga tdfx"
 for x in ${VIDEO_CARDS}; do
@@ -293,7 +293,7 @@ src_configure() {
                $(use_enable network networking)
                $(use_enable joystick)
        "
-       uses="bl bluray enca ftp rtc" # nemesi <- not working with in-tree ebuild
+       uses="bl bluray enca ftp rtc vcd" # nemesi <- not working with in-tree ebuild
        myconf+=" --disable-nemesi" # nemesi automagic disable
        for i in ${uses}; do
                use ${i} || myconf+=" --disable-${i}"
@@ -416,7 +416,7 @@ src_configure() {
        ################
        # Video Output #
        ################
-       uses="directfb md5sum sdl"
+       uses="directfb md5sum sdl yuv4mpeg"
        for i in ${uses}; do
                use ${i} || myconf+=" --disable-${i}"
        done