dev-python/hyper-h2: Version bump, bugfix release
authorBrian Dolbec <dolsen@gentoo.org>
Mon, 24 Oct 2016 23:10:35 +0000 (16:10 -0700)
committerBrian Dolbec <dolsen@gentoo.org>
Mon, 24 Oct 2016 23:16:02 +0000 (16:16 -0700)
Package-Manager: portage-2.3.2

dev-python/hyper-h2/Manifest
dev-python/hyper-h2/hyper-h2-2.4.1.ebuild [new file with mode: 0644]

index 5dad240cbf79a033cc8d955c609c4a4af1feb6a8..ebdc53b09d991e6b92ca40b0231897fb6fadbb12 100644 (file)
@@ -1 +1,2 @@
 DIST hyper-h2-2.4.0.tar.gz 77440 SHA256 c673efad0b8ee3c3c604375dd5e0c3dbc74f3c4e0385dae120d22b7d6f6ec301 SHA512 76835d6c97d4aed515b460bdbbcb8aea1ea061a416386cadf66a0e9b3c213a9ffe67948ce49b922d99e1895615a03159aa6aed198857e1ce73eb734b8bd9a016 WHIRLPOOL 9a5c1d313f53ee842403c77a8324aa432ff3d04d3d3737f6f7da83e5ff85e51ea6794419fa8886368cf34d4a7be3ff3b7ed19eb13a74ef8318fad738a71b9ef4
+DIST hyper-h2-2.4.1.tar.gz 78056 SHA256 a914161895f60a16d7049386c77f2eee72af7fd49b117856033906e16110c9f4 SHA512 f7a29350a3f31740acf6fc199fb5f3fa06d751abcfbf5a2742370c40c656417ccc659d49b9754e5faeb09ad121c362a478076af81325644d04473d56fc83b07a WHIRLPOOL 4917deb305cca78a6cc8fcfeb34e8f4ef8982c213edc7c3f242422e992d1105ccb151168ad7387fd53faca6061a693cf76f7cb3f91880470cd7bf03bb7a73b26
diff --git a/dev-python/hyper-h2/hyper-h2-2.4.1.ebuild b/dev-python/hyper-h2/hyper-h2-2.4.1.ebuild
new file mode 100644 (file)
index 0000000..fbf71d6
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy)
+
+inherit distutils-r1
+
+MY_PN="h2"
+
+DESCRIPTION="HTTP/2 State-Machine based protocol implementation"
+HOMEPAGE="http://python-hyper.org/h2 https://pypi.python.org/pypi/h2"
+SRC_URI="mirror://pypi/${P:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+       >=dev-python/hyperframe-4.0.1[${PYTHON_USEDEP}]
+       <dev-python/hyperframe-5.0.0[${PYTHON_USEDEP}]
+       >=dev-python/hpack-2.2.0[${PYTHON_USEDEP}]
+       <dev-python/hpack-3.0.0[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' python2_7)
+       $(python_gen_cond_dep '<dev-python/enum34-2.0.0[${PYTHON_USEDEP}]' python2_7)
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_PN}-${PV}