net-ftp/filezilla: Bump to version 3.42.1
authorLars Wendler <polynomial-c@gentoo.org>
Thu, 9 May 2019 19:52:13 +0000 (21:52 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Thu, 9 May 2019 19:52:33 +0000 (21:52 +0200)
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-ftp/filezilla/Manifest
net-ftp/filezilla/filezilla-3.42.1.ebuild [new file with mode: 0644]

index a2b035ce82c51810f2140bb7952c4aadb1d52a87..19535f8c86cbc23c8f00931f8e1b011b556f350a 100644 (file)
@@ -2,3 +2,4 @@ DIST FileZilla_3.39.0_src.tar.bz2 4995713 BLAKE2B d89aaa1f57187cd926ae1c4dd34624
 DIST FileZilla_3.40.0_src.tar.bz2 4997647 BLAKE2B 88ff2461d33369c435645f1dd5afa98c566141bf825e74898f870bd4c09cc7b47a70f605afbaf7be28855385812a28ea24303b6ec7f0ba605a793160c3b76027 SHA512 7aeb0c340111a47c435e8d8cbf379e83d2fc6c0a94038e085664df34c2fe1f8ef8496ea894f5e4cfd576d034e8935fe29661bb9eff9f22416032f45f5a66db2f
 DIST FileZilla_3.41.2_src.tar.bz2 4994803 BLAKE2B 34f8331d3dfe3bdf483d234a0473074e17954b7d16abb7276ee6276221091f085c802d8cb0d397e00159b408d2737f5e23f2e50ad19d344c82472c09eea4dcd1 SHA512 c4b8284896942ba46f8f88fc5d60c6893c719e28ab94463848060850b6f9b2f4d3d13f580551dc3b21ab25ffc0cb1f43a2750500b5be2117952e14512a7ee40c
 DIST FileZilla_3.42.0_src.tar.bz2 4985999 BLAKE2B 3713b732d9021fa61c71bfa0fae04e9ee743cc887c3807311a8d5fee5d6ee4e67159a0e6cf6b5048df3f68f44ddcb22744b6f5c7c74c90bf4103c1b85cf9afb4 SHA512 d3a273fc17d53785de693c67bfc318f281ee73694a136b440049f4efb32ee1e1f8a625141353ac33b5404303a786adb38d6b44659dda6b83788f39f7001342fd
+DIST FileZilla_3.42.1_src.tar.bz2 4987250 BLAKE2B 8cc6fd0a0cec336f34793520fe4be52a36a91ba5a4a3d41092d78c00a25899f73abd03f8d6339da40bc98a618dbae98063de2844a83cacb1431fc53f3b962383 SHA512 0dc9b3a6347803f60a71c56bb759700fb2b1b019dc29794aa639ce892ccd1ae53041112987f9d5e8e75ec7e07702a5aac8e1c131796bbc5f210d75d286276deb
diff --git a/net-ftp/filezilla/filezilla-3.42.1.ebuild b/net-ftp/filezilla/filezilla-3.42.1.ebuild
new file mode 100644 (file)
index 0000000..7110b88
--- /dev/null
@@ -0,0 +1,83 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WX_GTK_VER="3.0-gtk3"
+
+inherit autotools flag-o-matic wxwidgets xdg
+
+MY_PV=${PV/_/-}
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="https://filezilla-project.org/"
+SRC_URI="https://download.filezilla-project.org/client/${MY_P}_src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86"
+IUSE="dbus nls test"
+
+# pugixml 1.7 minimal dependency is for c++11 proper configuration
+RDEPEND=">=app-eselect/eselect-wxwidgets-0.7-r1
+       >=dev-libs/nettle-3.1:=
+       >=dev-db/sqlite-3.7
+       >=dev-libs/libfilezilla-0.16.0
+       >=dev-libs/pugixml-1.7
+       >=net-libs/gnutls-3.5.7
+       >=x11-libs/wxGTK-3.0.4:${WX_GTK_VER}[X]
+       x11-misc/xdg-utils
+       dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       >=sys-devel/libtool-1.4
+       nls? ( >=sys-devel/gettext-0.11 )
+       test? ( >=dev-util/cppunit-1.13.0 )"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+DOCS=(AUTHORS ChangeLog NEWS )
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-3.22.1-debug.patch
+)
+
+pkg_pretend() {
+       if [[ ${MERGE_TYPE} != binary ]]; then
+               if ! test-flag-CXX -std=c++14; then
+                       eerror "${P} requires C++14-capable C++ compiler. Your current compiler"
+                       eerror "does not seem to support -std=c++14 option. Please upgrade your compiler"
+                       eerror "to gcc-4.9 or an equivalent version supporting C++14."
+                       die "Currently active compiler does not support -std=c++14"
+               fi
+       fi
+}
+
+src_prepare() {
+       setup-wxwidgets
+       default
+       eautoreconf
+}
+
+src_configure() {
+       local myeconfargs=(
+               --disable-autoupdatecheck
+               --with-pugixml=system
+               $(use_enable nls locales)
+               $(use_with dbus)
+       )
+       econf "${myeconfargs[@]}"
+}
+
+pkg_preinst() {
+       xdg_pkg_preinst
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+}