dev-ros/navfn: Bump to 1.16.6.
authorAlexis Ballier <aballier@gentoo.org>
Mon, 18 May 2020 14:29:30 +0000 (16:29 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 18 May 2020 15:18:20 +0000 (17:18 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ros/navfn/Manifest
dev-ros/navfn/navfn-1.16.6.ebuild [new file with mode: 0644]

index dfc8b47bf1753e7fabcc755a4430127ca4aeeef8..70abd4ab2ddeac07249df77aad04df0bbd762918 100644 (file)
@@ -1 +1,2 @@
 DIST navigation-1.16.3.tar.gz 342459 BLAKE2B 736414787adee9c7511b0d90276395d33b9b52207d55ddd53836c9d77cb6809bf1946443878ad83e4461d0febf05b616b93ec0a18b34ed402323eb9bbb100861 SHA512 2eddb27fd3eff143674cc518be520e6df4d24a965689441f710105977f4bbe307736df5e6303319dde99362187091ea4f90eaec9da5a4bc678250410af174a71
+DIST navigation-1.16.6.tar.gz 346529 BLAKE2B ed2d7ddd0ca9525f0ae22711d65fc2ede5f3046fd320e5016b93505616c4d476d65128695ff8830c4fa0b8dbdc276a1ec5951fdb4d0516f4d5f70897e4759f31 SHA512 c6bc3db39457c6bccba7ee2646504c4e1c91840a3297bdb9b92b28d93c608c0de113eb92527d4f499232de628d5b49816ec42522043500b20fb04056e2a7c97f
diff --git a/dev-ros/navfn/navfn-1.16.6.ebuild b/dev-ros/navfn/navfn-1.16.6.ebuild
new file mode 100644 (file)
index 0000000..fc41aa5
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs dev-ros/nav_msgs"
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Fast interpolated navigation function that can be used to create plans for a mobile base"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       >=dev-ros/costmap_2d-1.16
+       dev-ros/nav_core
+       dev-ros/pluginlib
+       dev-ros/rosconsole
+       dev-ros/roscpp
+       dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/tf2_ros
+       dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+
+       dev-cpp/eigen:3
+       x11-libs/fltk
+       media-libs/netpbm
+       dev-libs/boost:=[threads]
+       dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+       test? ( dev-cpp/gtest )
+       dev-ros/cmake_modules"
+
+PATCHES=( "${FILESDIR}/pgm_h_location.patch" "${FILESDIR}/tests.patch" )
+
+src_prepare() {
+       ros-catkin_src_prepare
+       sed -e "s#@PGM_PATH@#\"${S}/test/willow_costmap.pgm\"#" -i test/path_calc_test.cpp || die
+}