net-im/telegram-desktop: bump to 1.9.20
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Sun, 15 Mar 2020 19:12:24 +0000 (12:12 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Sun, 15 Mar 2020 19:13:41 +0000 (12:13 -0700)
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
net-im/telegram-desktop/Manifest
net-im/telegram-desktop/files/1.9.20-gcc9.patch [new file with mode: 0644]
net-im/telegram-desktop/telegram-desktop-1.9.20.ebuild [new file with mode: 0644]

index 61025523b0063b3984fedd7c3d667cec5b0de11a..3eecdabeb0174d5d4089e9e46886da2d97110c4c 100644 (file)
@@ -1,2 +1,3 @@
 DIST tdesktop-1.9.14-full.tar.gz 25324084 BLAKE2B 45c071aa573541b6e483d2ae712b7f3b672c1294e8e7e624d9292f7176482f4d68069c35541019dc27fdb1c66134c29fb4d3667f1197e7085e4f8a80c8ca603c SHA512 56efa64048d23b280782b51319c0071c6cef833cb7e2584e52c6e45488577755beb85185ec9187029c425cc8d4c9c1887142687c744697e7731a15abe2846056
 DIST tdesktop-1.9.19-full.tar.gz 25840478 BLAKE2B 1a730e74df71af0c8fcc579fb1b2546fe279d64dd60786a32e015dbc0046a5d4a933bfdc128f7bb2b624705e6788ec6d597ceeb328f91dc173d1c5a0e739a29c SHA512 29070c6e1d813943d5062dc1703f383a18323b5698fbc4e6f2c89b33366da9da5d1ec84dc29950288e7e7d112024de2924244ec9c800d59d4b210e6288c7291d
+DIST tdesktop-1.9.20-full.tar.gz 25847905 BLAKE2B 228e7ad703bf3c3ca5ac198d099b0c747ddce31fbf7f93b46084043b0d02f36df54f684ee1cddb1040ff83cb1d5c41a05e84e045c68fba4bf13c864ab0b29e80 SHA512 d4f3b57a5b34f47b9a35517d15f7296509e9b2a160d6c8b77aae1c791e13c5171409c32be371bd8191bb8fbde3e32d03c380a99b5587a98c38b93f34c8cd7b52
diff --git a/net-im/telegram-desktop/files/1.9.20-gcc9.patch b/net-im/telegram-desktop/files/1.9.20-gcc9.patch
new file mode 100644 (file)
index 0000000..4fef1aa
--- /dev/null
@@ -0,0 +1,36 @@
+From cf89b5a94411afa9d3f36e9f27e40426f8899bc1 Mon Sep 17 00:00:00 2001
+From: Ilya Fedin <fedin-ilja2010@ya.ru>
+Date: Sat, 14 Mar 2020 23:35:51 +0400
+Subject: [PATCH] Fix build with gcc 9
+
+---
+ .../SourceFiles/platform/linux/notifications_manager_linux.cpp  | 2 +-
+ Telegram/SourceFiles/platform/linux/specific_linux.cpp          | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Telegram/SourceFiles/platform/linux/notifications_manager_linux.cpp b/Telegram/SourceFiles/platform/linux/notifications_manager_linux.cpp
+index 6b9057437d..86382ab812 100644
+--- a/Telegram/SourceFiles/platform/linux/notifications_manager_linux.cpp
++++ b/Telegram/SourceFiles/platform/linux/notifications_manager_linux.cpp
+@@ -104,7 +104,7 @@ bool Inhibited() {
+       const QDBusReply<QVariant> reply = QDBusConnection::sessionBus().call(
+               message);
+-      constexpr auto notSupportedErrors = {
++      const auto notSupportedErrors = {
+               QDBusError::ServiceUnknown,
+               QDBusError::InvalidArgs,
+       };
+diff --git a/Telegram/SourceFiles/platform/linux/specific_linux.cpp b/Telegram/SourceFiles/platform/linux/specific_linux.cpp
+index b9c5d3f0b8..916a26360f 100644
+--- a/Telegram/SourceFiles/platform/linux/specific_linux.cpp
++++ b/Telegram/SourceFiles/platform/linux/specific_linux.cpp
+@@ -374,7 +374,7 @@ std::optional<crl::time> LastUserInputTime() {
+       const QDBusReply<uint> reply = QDBusConnection::sessionBus().call(
+               message);
+-      constexpr auto notSupportedErrors = {
++      const auto notSupportedErrors = {
+               QDBusError::ServiceUnknown,
+               QDBusError::NotSupported,
+       };
diff --git a/net-im/telegram-desktop/telegram-desktop-1.9.20.ebuild b/net-im/telegram-desktop/telegram-desktop-1.9.20.ebuild
new file mode 100644 (file)
index 0000000..9741e17
--- /dev/null
@@ -0,0 +1,143 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit cmake desktop flag-o-matic python-any-r1 xdg-utils
+
+MY_P="tdesktop-${PV}-full"
+
+DESCRIPTION="Official desktop client for Telegram"
+HOMEPAGE="https://desktop.telegram.org"
+SRC_URI="https://github.com/telegramdesktop/tdesktop/releases/download/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3-with-openssl-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE="+alsa +dbus enchant +hunspell libressl pulseaudio +spell"
+
+RDEPEND="
+       !net-im/telegram-desktop-bin
+       app-arch/lz4:=
+       app-arch/xz-utils
+       !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:0= )
+       >=dev-cpp/ms-gsl-2.1.0
+       dev-cpp/range-v3
+       dev-libs/xxhash
+       dev-qt/qtcore:5
+       dev-qt/qtimageformats:5
+       dev-qt/qtnetwork:5
+       dev-qt/qtsvg:5
+       media-libs/fontconfig:=
+       >=media-libs/libtgvoip-2.4.4_p20200301[alsa?,pulseaudio?]
+       media-libs/openal[alsa?,pulseaudio?]
+       media-libs/opus:=
+       media-video/ffmpeg:=[opus]
+       sys-libs/zlib[minizip]
+       virtual/libiconv
+       x11-libs/libva:=[X,drm]
+       x11-libs/libX11
+       || (
+               dev-qt/qtgui:5[jpeg,png,X(-)]
+               dev-qt/qtgui:5[jpeg,png,xcb(-)]
+       )
+       || (
+               dev-qt/qtwidgets:5[png,X(-)]
+               dev-qt/qtwidgets:5[png,xcb(-)]
+       )
+       dbus? (
+               dev-qt/qtdbus:5
+               dev-libs/libdbusmenu-qt[qt5(+)]
+       )
+       enchant? ( app-text/enchant:= )
+       hunspell? ( >=app-text/hunspell-1.7:= )
+       pulseaudio? ( media-sound/pulseaudio )
+"
+
+DEPEND="
+       ${PYTHON_DEPS}
+       ${RDEPEND}
+"
+
+BDEPEND="
+       >=dev-util/cmake-3.16
+       virtual/pkgconfig
+"
+
+REQUIRED_USE="|| ( alsa pulseaudio )
+       spell? (
+               ^^ ( enchant hunspell )
+       )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+       "${FILESDIR}/1.9.20-gcc9.patch"
+)
+
+src_configure() {
+       local mycxxflags=(
+               -Wno-deprecated-declarations
+               -Wno-error=deprecated-declarations
+               -Wno-switch
+       )
+
+       append-cxxflags "${mycxxflags[@]}"
+
+       # TODO: unbundle header-only libs, ofc telegram uses git versions...
+       # it fals with tl-expected-1.0.0, so we use bundled for now to avoid git rev snapshots
+       # EXPECTED VARIANT
+       local mycmakeargs=(
+               -DDESKTOP_APP_DISABLE_CRASH_REPORTS=ON
+               -DDESKTOP_APP_USE_GLIBC_WRAPS=OFF
+               -DDESKTOP_APP_USE_PACKAGED=ON
+               -DDESKTOP_APP_USE_PACKAGED_EXPECTED=OFF
+               -DDESKTOP_APP_USE_PACKAGED_RLOTTIE=OFF
+               -DDESKTOP_APP_USE_PACKAGED_VARIANT=OFF
+               -DTDESKTOP_LAUNCHER_BASENAME="${PN}"
+               -DDESKTOP_APP_DISABLE_DBUS_INTEGRATION="$(usex dbus OFF ON)"
+               -DDESKTOP_APP_DISABLE_SPELLCHECK="$(usex spell OFF ON)" # enables hunspell
+               -DDESKTOP_APP_USE_ENCHANT="$(usex enchant ON OFF)" # enables enchant and disables hunspell
+       )
+
+       if [[ -n ${MY_TDESKTOP_API_ID} && -n ${MY_TDESKTOP_API_HASH} ]]; then
+               einfo "Found custom API credentials"
+               mycmakeargs+=(
+                       -DTDESKTOP_API_ID="${MY_TDESKTOP_API_ID}"
+                       -DTDESKTOP_API_HASH="${MY_TDESKTOP_API_HASH}"
+               )
+       else
+               # https://github.com/telegramdesktop/tdesktop/blob/dev/snap/snapcraft.yaml
+               # Building with snapcraft API credentials by default
+               # Custom API credentials can be obtained here:
+               # https://github.com/telegramdesktop/tdesktop/blob/dev/docs/api_credentials.md
+               # After getting credentials you can export variables:
+               #  export MY_TDESKTOP_API_ID="17349""
+               #  export MY_TDESKTOP_API_HASH="344583e45741c457fe1862106095a5eb"
+               # and restart the build"
+               # you can set above variables (without export) in /etc/portage/env/net-im/telegram-desktop
+               # portage will use custom variable every build automatically
+               mycmakeargs+=(
+                       -DTDESKTOP_API_ID="611335"
+                       -DTDESKTOP_API_HASH="d524b414d21f4d37f08684c1df41ac9c"
+               )
+       fi
+
+       cmake_src_configure
+}
+
+pkg_postinst() {
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+       xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+       xdg_mimeinfo_database_update
+}