app-crypt/libb2: move away from ltprune.eclass
authorFabian Groffen <grobian@gentoo.org>
Wed, 5 Jun 2019 08:35:48 +0000 (10:35 +0200)
committerFabian Groffen <grobian@gentoo.org>
Wed, 5 Jun 2019 08:36:51 +0000 (10:36 +0200)
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

app-crypt/libb2/libb2-0.98.1.ebuild
app-crypt/libb2/libb2-0.98.ebuild

index 3212a3234b035729178a8e3af2b78e348925aeb2..33493fbb9ef10d071c9f5e3845fc98ba4ab35b83 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-inherit autotools ltprune toolchain-funcs
+inherit autotools toolchain-funcs
 
 DESCRIPTION="C library providing BLAKE2b, BLAKE2s, BLAKE2bp, BLAKE2sp"
 HOMEPAGE="https://github.com/BLAKE2/libb2"
@@ -53,5 +53,5 @@ src_compile() {
 
 src_install() {
        default
-       prune_libtool_files
+       use static || find "${ED}" -name '*.la' -type f -delete || die
 }
index 3ca37501441bbd16dd426e54ebf4237011e49a75..64ec18c1de9ef27b1e63de5ce2085d8d82e994b4 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
-inherit autotools ltprune
+inherit autotools
 
 DESCRIPTION="C library providing BLAKE2b, BLAKE2s, BLAKE2bp, BLAKE2sp"
 HOMEPAGE="https://github.com/BLAKE2/libb2"
@@ -40,5 +40,5 @@ src_compile() {
 
 src_install() {
        default
-       prune_libtool_files
+       use static || find "${ED}" -name '*.la' -type f -delete || die
 }