dev-python/pyftpdlib: skip failing tests for v1.5.4
authorLouis Sautier <sbraz@gentoo.org>
Wed, 27 Jun 2018 21:44:11 +0000 (23:44 +0200)
committerLouis Sautier <sbraz@gentoo.org>
Wed, 27 Jun 2018 21:44:11 +0000 (23:44 +0200)
Closes: https://bugs.gentoo.org/659108
Closes: https://bugs.gentoo.org/636410
Package-Manager: Portage-2.3.40, Repoman-2.3.9

dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild

index 8086ddd2bcdd978ef356f6be9a4ec3a500ffdda9..14ef11ae7fecbb737d1a3daeaaced6b962c26356 100644 (file)
@@ -31,6 +31,7 @@ DEPEND="
                dev-python/psutil[${PYTHON_USEDEP}]
                dev-python/pyopenssl[${PYTHON_USEDEP}]
                dev-python/pysendfile[${PYTHON_USEDEP}]
+               dev-python/pytest[${PYTHON_USEDEP}]
        )
 "
 
@@ -47,7 +48,15 @@ python_compile_all() {
 }
 
 python_test() {
-       "${EPYTHON}" ${PN}/test/runner.py || die "Tests failed with ${EPYTHON}"
+       # Skip tests which sometimes fail:
+       # https://github.com/giampaolo/pyftpdlib/issues/470
+       # https://github.com/giampaolo/pyftpdlib/issues/471
+       py.test --ignore ${PN}/test/test_misc.py -k \
+               "not (test_idle_data_timeout2 or test_on_incomplete_file_received)" \
+               || die "Tests failed with ${EPYTHON}"
+       # These tests fail when passing additional options to py.test
+       # so we need to run them separately
+       py.test ${PN}/test/test_misc.py || die "Tests failed with ${EPYTHON}"
 }
 
 python_install_all() {