app-editors/hteditor: update to EAPI 6 and add ncurses slot dep
authorTim Harder <radhermit@gentoo.org>
Sat, 21 Jan 2017 09:50:41 +0000 (04:50 -0500)
committerTim Harder <radhermit@gentoo.org>
Sat, 21 Jan 2017 09:54:55 +0000 (04:54 -0500)
app-editors/hteditor/hteditor-2.1.0.ebuild

index bd55f0dae50b187e48618cb3563b06f37cc0d731..a7ff98cae4cecdc802a675f1646be568a999d683 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-EAPI=5
+EAPI=6
 
 inherit toolchain-funcs
 
@@ -17,7 +17,7 @@ SLOT="0"
 KEYWORDS="amd64 ppc ppc64 x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
 IUSE="X"
 
-RDEPEND="sys-libs/ncurses
+RDEPEND="sys-libs/ncurses:0=
        X? ( x11-libs/libX11 )
        >=dev-libs/lzo-2"
 DEPEND="${RDEPEND}
@@ -42,8 +42,8 @@ src_install() {
        #For prefix
        chmod u+x "${S}/install-sh"
 
-       default
-
-       dohtml doc/*.html
+       local HTML_DOCS="doc/*.html"
        doinfo doc/*.info
+
+       default
 }