app-eselect/eselect-pdftex: port to EAPI=7
authorMikle Kolyada <zlogene@gentoo.org>
Fri, 25 Oct 2019 08:24:05 +0000 (11:24 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Fri, 25 Oct 2019 08:24:05 +0000 (11:24 +0300)
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
app-eselect/eselect-pdftex/eselect-pdftex-0.3.ebuild

index 247a456d8949888d3bf5fd54f26c3a4e24230ed5..561e5f27b81441db6d50612418bea1b902ad47c5 100644 (file)
@@ -1,9 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
-
-inherit eutils
+EAPI=7
 
 DESCRIPTION="pdftex module for eselect"
 HOMEPAGE="https://www.gentoo.org/proj/en/eselect/"
@@ -12,7 +10,6 @@ SRC_URI=""
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="alpha amd64 arm hppa ia64 ~ppc ~ppc64 s390 sh sparc x86"
-IUSE=""
 
 DEPEND=""
 # Depend on texlive-core-2008 that allows usage of this module, otherwise it
@@ -20,11 +17,12 @@ DEPEND=""
 RDEPEND=">=app-admin/eselect-1.2.3
        >=app-text/texlive-core-2008"
 
+S="${WORKDIR}"
+
 src_install() {
        local MODULEDIR="/usr/share/eselect/modules"
        local MODULE="pdftex"
        dodir ${MODULEDIR}
        insinto ${MODULEDIR}
-       newins "${FILESDIR}/${MODULE}.eselect-${PVR}" ${MODULE}.eselect \
-               || die "failed to install"
+       newins "${FILESDIR}/${MODULE}.eselect-${PVR}" ${MODULE}.eselect
 }