Fix broken autotools handling.
authorDiego Elio Pettenò <flameeyes@gentoo.org>
Thu, 4 Jan 2007 14:31:59 +0000 (14:31 +0000)
committerDiego Elio Pettenò <flameeyes@gentoo.org>
Thu, 4 Jan 2007 14:31:59 +0000 (14:31 +0000)
Package-Manager: portage-2.1.2_rc4-r5

dev-cpp/gconfmm/ChangeLog
dev-cpp/gconfmm/gconfmm-2.12.0.ebuild
dev-cpp/gnome-vfsmm/ChangeLog
dev-cpp/gnome-vfsmm/gnome-vfsmm-2.12.0.ebuild

index ded50dbb1f8c3e0ff6f8245d6b457e14e380e9ab..8cb123967c9d5917ae5447d691c92673900c7e0d 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for dev-cpp/gconfmm
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gconfmm/ChangeLog,v 1.44 2006/09/11 16:15:12 allanonjl Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gconfmm/ChangeLog,v 1.45 2007/01/04 14:30:22 flameeyes Exp $
+
+  04 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> gconfmm-2.12.0.ebuild:
+  Fix broken autotools handling.
 
 *gconfmm-2.16.0 (11 Sep 2006)
 
index 72097d8682598f9776afbe737799433f643cb32b..150d9e09a6237ad58a7c4a9a9b23274f7a7e0b57 100644 (file)
@@ -1,8 +1,11 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gconfmm/gconfmm-2.12.0.ebuild,v 1.13 2006/08/13 18:03:36 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gconfmm/gconfmm-2.12.0.ebuild,v 1.14 2007/01/04 14:30:22 flameeyes Exp $
 
-inherit gnome2 eutils
+WANT_AUTOMAKE="latest"
+WANT_AUTOCONF="latest"
+
+inherit gnome2 eutils autotools
 
 DESCRIPTION="C++ bindings for GConf"
 HOMEPAGE="http://gtkmm.sourceforge.net/"
@@ -21,13 +24,11 @@ DEPEND=">=dev-util/pkgconfig-0.12.0
 
 DOCS="AUTHORS COPYING* ChangeLog NEWS README INSTALL"
 
-src_compile() {
-       if useq amd64; then
-               aclocal -I scripts
-               libtoolize --force --copy
-               automake -c -f
-               autoconf
-       fi
+src_unpack() {
+       gnome2_src_unpack
+       eautoreconf
+}
 
+src_compile() {
        gnome2_src_compile
 }
index 30c270441a1b847e16fbdd71d2331525df31dc15..20a972457f07cc31d74f2508d8b7a2b56100e517 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for dev-cpp/gnome-vfsmm
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gnome-vfsmm/ChangeLog,v 1.33 2006/10/21 10:54:40 dertobi123 Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gnome-vfsmm/ChangeLog,v 1.34 2007/01/04 14:31:59 flameeyes Exp $
+
+  04 Jan 2007; Diego Pettenò <flameeyes@gentoo.org>
+  gnome-vfsmm-2.12.0.ebuild:
+  Fix broken autotools handling.
 
   21 Oct 2006; Tobias Scherbaum <dertobi123@gentoo.org>
   gnome-vfsmm-1.3.5.ebuild:
index faf79a194fcbc2da7c8e2a12d393905b729e755a..eb23afa7401ada13f33c04e2b927080e7f58553b 100644 (file)
@@ -1,8 +1,11 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gnome-vfsmm/gnome-vfsmm-2.12.0.ebuild,v 1.13 2006/08/13 18:14:47 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gnome-vfsmm/gnome-vfsmm-2.12.0.ebuild,v 1.14 2007/01/04 14:31:59 flameeyes Exp $
 
-inherit gnome2
+WANT_AUTOMAKE="latest"
+WANT_AUTOCONF="latest"
+
+inherit gnome2 autotools
 
 DESCRIPTION="C++ bindings for gnome-vfs"
 HOMEPAGE="http://gtkmm.sourceforge.net/"
@@ -19,13 +22,7 @@ DEPEND=">=dev-util/pkgconfig-0.12.0
 
 DOCS="AUTHORS ChangeLog NEWS README INSTALL"
 
-src_compile() {
-       if useq amd64; then
-               aclocal -I scripts
-               automake -c -f
-               autoconf
-               libtoolize      --copy --force
-       fi
-
-       gnome2_src_compile
+src_unpack() {
+       gnome2_src_unpack
+       AT_M4DIR="scripts" eautoreconf
 }