app-vim/vimtex: remove bad dependencies.
authorPatrice Clement <monsieurp@gentoo.org>
Fri, 13 Dec 2019 08:25:51 +0000 (09:25 +0100)
committerPatrice Clement <monsieurp@gentoo.org>
Fri, 13 Dec 2019 08:26:30 +0000 (09:26 +0100)
Closes: https://bugs.gentoo.org/688584
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
app-vim/vimtex/vimtex-20180324-r1.ebuild [new file with mode: 0644]
app-vim/vimtex/vimtex-99999999.ebuild

diff --git a/app-vim/vimtex/vimtex-20180324-r1.ebuild b/app-vim/vimtex/vimtex-20180324-r1.ebuild
new file mode 100644 (file)
index 0000000..fc0060e
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+if [[ ${PV} == 9999* ]]; then
+       EGIT_REPO_URI="https://github.com/lervag/vimtex.git"
+       inherit git-r3
+else
+       inherit vcs-snapshot
+       COMMIT_HASH="17d809706edcb277f1ee7fa5e33aff3619926fe4"
+       SRC_URI="https://github.com/lervag/vimtex/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: a modern vim plugin for editing LaTeX files"
+HOMEPAGE="https://github.com/lervag/vimtex"
+LICENSE="MIT"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+RDEPEND="
+       !app-vim/vim-latex
+       !app-vim/automatictexplugin"
+
+src_prepare() {
+       default
+
+       # remove unwanted files
+       rm -r *.md media test || die
+}
index d4031034c01462af5e1fc18d9d475ad4016082a2..fc0060ecefde866d11ce517741971241332ba6c5 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -23,10 +23,7 @@ VIM_PLUGIN_HELPFILES="${PN}"
 
 RDEPEND="
        !app-vim/vim-latex
-       !app-vim/automatictexplugin
-       virtual/latex-base
-       dev-tex/latexmk
-"
+       !app-vim/automatictexplugin"
 
 src_prepare() {
        default