dev-python/unidecode: add Python 3.7, PyPy3, EAPI=7, fix LICENSE
authorLouis Sautier <sbraz@gentoo.org>
Tue, 18 Sep 2018 23:18:28 +0000 (01:18 +0200)
committerLouis Sautier <sbraz@gentoo.org>
Tue, 18 Sep 2018 23:21:37 +0000 (01:21 +0200)
Package-Manager: Portage-2.3.49, Repoman-2.3.10

dev-python/unidecode/unidecode-1.0.22.ebuild

index af46dbffb7d19ec383ddaae74be0c1540b16bc73..fcf847f5df2dd0c1ea58a9c74159a57e1796a203 100644 (file)
@@ -1,9 +1,9 @@
 # Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
 
 MY_PN=Unidecode
 MY_P=${MY_PN}-${PV}
@@ -14,13 +14,13 @@ DESCRIPTION="Module providing ASCII transliterations of Unicode text"
 HOMEPAGE="https://pypi.org/project/Unidecode/"
 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
 
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
 
 S=${WORKDIR}/${MY_P}
 
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
 
 python_test() {
        esetup.py test