Skip the most expensive QA tests when --force in enabled since there's no
authorZac Medico <zmedico@gentoo.org>
Thu, 6 Sep 2007 17:52:39 +0000 (17:52 -0000)
committerZac Medico <zmedico@gentoo.org>
Thu, 6 Sep 2007 17:52:39 +0000 (17:52 -0000)
point in wasting time on them when the user is intent on forcing the commit
anyway. (trunk r7713)

svn path=/main/branches/2.1.2/; revision=7741

bin/repoman

index 4c98eb9314728a867c32414ce5b2cbc95c9452e7..c7f60592c4f7ed8f1d8ee603637b854c8d1ea7ac 100755 (executable)
@@ -1247,6 +1247,12 @@ for x in scanlist:
                                stats["usage.obsolete"] += 1
                                fails["usage.obsolete"].append("%s/%s.ebuild: not migrated to modular X" % (x, y))
 
+               if "--force" in myoptions:
+                       # The dep_check() calls are the most expensive QA test. If --force
+                       # is enabled, there's no point in wasting time on these since the
+                       # user is intent on forcing the commit anyway.
+                       continue
+
                for keyword,arch,groups in arches:
 
                        if not profiles.has_key(arch):