app-crypt/argon2: Fix version for pkg-config file
authorMichał Górny <mgorny@gentoo.org>
Sat, 28 Dec 2019 19:39:25 +0000 (20:39 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 28 Dec 2019 19:44:16 +0000 (20:44 +0100)
Override upstream version number to '0~DATE' to match other
distributions and fix compatibility with revdeps.

Closes: https://bugs.gentoo.org/703976
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-crypt/argon2/argon2-20190702.ebuild

index 18de3ac70aa8d07c3d7bf64203c9ab9e809a489b..5a1f62a6b924ea6531994512ac0ba179cb8fb190 100644 (file)
@@ -39,7 +39,8 @@ src_prepare() {
 }
 
 src_compile() {
-       emake OPTTEST="${OPTTEST}" LIBRARY_REL="$(get_libdir)"
+       emake OPTTEST="${OPTTEST}" LIBRARY_REL="$(get_libdir)" \
+               ARGON2_VERSION="0~${PV}"
 }
 
 src_test() {