dev-python/twisted: Fix stray % in var refs
authorMichał Górny <mgorny@gentoo.org>
Thu, 13 Feb 2020 10:41:05 +0000 (11:41 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 13 Feb 2020 10:42:02 +0000 (11:42 +0100)
Closes: https://bugs.gentoo.org/709470
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/twisted/twisted-19.10.0.ebuild

index 6491d91917f8895bdffd1c64ea4540f98150a882..6de8b0c43fb5d7fbcc68efef93e24251ab5f3a98 100644 (file)
@@ -127,7 +127,7 @@ python_test() {
 python_install() {
        distutils-r1_python_install
 
-       cd "${D%}$(python_get_sitedir)" || die
+       cd "${D}$(python_get_sitedir)" || die
 
        # own the dropin.cache so we don't leave orphans
        touch twisted/plugins/dropin.cache || die
@@ -162,7 +162,7 @@ pkg_postinst() {
 }
 
 python_postrm() {
-       rm -f "${ROOT%}$(python_get_sitedir)/twisted/plugins/dropin.cache" || die
+       rm -f "${ROOT}$(python_get_sitedir)/twisted/plugins/dropin.cache" || die
 }
 
 pkg_postrm(){