xfce-extra/xfce4-vala: Bump to EAPI 7, port off xfconf
authorMichał Górny <mgorny@gentoo.org>
Tue, 9 Apr 2019 15:07:39 +0000 (17:07 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 9 Apr 2019 16:09:02 +0000 (18:09 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
xfce-extra/xfce4-vala/xfce4-vala-4.10.3-r4.ebuild [new file with mode: 0644]

diff --git a/xfce-extra/xfce4-vala/xfce4-vala-4.10.3-r4.ebuild b/xfce-extra/xfce4-vala/xfce4-vala-4.10.3-r4.ebuild
new file mode 100644 (file)
index 0000000..e2874c8
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION=0.32
+VALA_MAX_API_VERSION=${VALA_MIN_API_VERSION}
+VALA_USE_DEPEND=vapigen
+inherit vala
+
+DESCRIPTION="Vala bindings for the Xfce desktop environment"
+HOMEPAGE="https://wiki.xfce.org/vala-bindings"
+SRC_URI="https://archive.xfce.org/src/bindings/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="$(vala_depend)
+       >=xfce-base/exo-0.10:=
+       >=xfce-base/garcon-0.2:=
+       >=xfce-base/libxfce4ui-4.10:=
+       >=xfce-base/libxfce4util-4.10:=
+       >=xfce-base/xfce4-panel-4.10:=
+       >=xfce-base/xfconf-4.10:="
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+src_prepare() {
+       default
+}
+
+src_configure() {
+       local myconf=(
+               "--with-vala-api=${VALA_MIN_API_VERSION}"
+       )
+
+       vala_src_prepare
+       econf "${myconf[@]}"
+}