dev-ros/rosbag_storage: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 13:40:15 +0000 (15:40 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 14:36:26 +0000 (16:36 +0200)
Package-Manager: portage-2.2.21

dev-ros/rosbag_storage/Manifest [new file with mode: 0644]
dev-ros/rosbag_storage/metadata.xml [new file with mode: 0644]
dev-ros/rosbag_storage/rosbag_storage-1.11.14.ebuild [new file with mode: 0644]
dev-ros/rosbag_storage/rosbag_storage-9999.ebuild [new file with mode: 0644]

diff --git a/dev-ros/rosbag_storage/Manifest b/dev-ros/rosbag_storage/Manifest
new file mode 100644 (file)
index 0000000..84bda76
--- /dev/null
@@ -0,0 +1 @@
+DIST ros_comm-1.11.14.tar.gz 945041 SHA256 8e7beff35711b1918501c69cca4f29648d4d4207878edab069bcd59d515c78f3 SHA512 be768faa0a2f45c464e963934a95dc617cac6c3fcec2388602a27846774c25b882b5139099ce10d1d051a21d5938819942e079836d14618071bc7ad90ee78bab WHIRLPOOL e047ce984086655294c20dbf0715cc29f51ec358f075f02de80c5de0d4ef8059990dc8312d78d7a7fa91c4a974dc21cba15d6eacafe02fd3df527770e50f75a5
diff --git a/dev-ros/rosbag_storage/metadata.xml b/dev-ros/rosbag_storage/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/rosbag_storage/rosbag_storage-1.11.14.ebuild b/dev-ros/rosbag_storage/rosbag_storage-1.11.14.ebuild
new file mode 100644 (file)
index 0000000..ebb742b
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Set of tools for recording from and playing back ROS message"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-libs/console_bridge
+       dev-ros/cpp_common
+       dev-ros/roscpp_serialization
+       dev-ros/roscpp_traits
+       dev-ros/rostime
+       dev-ros/roslz4
+       dev-libs/boost:=
+       app-arch/bzip2
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rosbag_storage/rosbag_storage-9999.ebuild b/dev-ros/rosbag_storage/rosbag_storage-9999.ebuild
new file mode 100644 (file)
index 0000000..ebb742b
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Set of tools for recording from and playing back ROS message"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-libs/console_bridge
+       dev-ros/cpp_common
+       dev-ros/roscpp_serialization
+       dev-ros/roscpp_traits
+       dev-ros/rostime
+       dev-ros/roslz4
+       dev-libs/boost:=
+       app-arch/bzip2
+"
+DEPEND="${RDEPEND}"