app-text/vilistextum-2.8.0.20191023-r1: add fix for list alignment
authorFabian Groffen <grobian@gentoo.org>
Thu, 13 Feb 2020 19:21:24 +0000 (20:21 +0100)
committerFabian Groffen <grobian@gentoo.org>
Thu, 13 Feb 2020 19:21:39 +0000 (20:21 +0100)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
app-text/vilistextum/files/vilistextum-2.8.0-list-alignment.patch [new file with mode: 0644]
app-text/vilistextum/vilistextum-2.8.0.20191023-r1.ebuild [moved from app-text/vilistextum/vilistextum-2.8.0.20191023.ebuild with 97% similarity]

diff --git a/app-text/vilistextum/files/vilistextum-2.8.0-list-alignment.patch b/app-text/vilistextum/files/vilistextum-2.8.0-list-alignment.patch
new file mode 100644 (file)
index 0000000..c308cfe
--- /dev/null
@@ -0,0 +1,43 @@
+--- a/src/lists.c
++++ b/src/lists.c
+@@ -74,6 +74,7 @@
+       }
+       spaces += tab;
++      orderedlist++;
+ #ifdef proc_debug
+       printf("start_uls() ende\n");
+ #endif
+@@ -82,6 +83,7 @@
+ void end_uls()
+ {
+       spaces -= tab;
++      orderedlist--;
+       line_break();
+       if (bullet_style=='%') { bullet_style='$'; }
+--- a/src/text.c
++++ b/src/text.c
+@@ -387,7 +387,11 @@
+                       }
+                       i=0;
+                       while (i<spaces) { zeile_plus_wort(ONESPACE,1,1); i++; }
+-                      if (orderedlist>0) { zeile_plus_wort(ONESPACE,1,1); }
++                      if (orderedlist>0)
++                      {
++                              i=(spaces%tab) + 1;
++                              while (i>0) { zeile_plus_wort(ONESPACE,1,1); i--; }
++                      }
+                       zeile_plus_wort(wort, wort_len, wort_pos);
+               }
+               else if (zeilen_len != 0)
+--- a/src/text.h
++++ b/src/text.h
+@@ -27,6 +27,7 @@
+ int tab;
+ int spaces;
+ int quote;
++int orderedlist;
+ void print_zeile();
+ int is_zeile_empty();
similarity index 97%
rename from app-text/vilistextum/vilistextum-2.8.0.20191023.ebuild
rename to app-text/vilistextum/vilistextum-2.8.0.20191023-r1.ebuild
index d77ae962a94bdfee0cd3f9b9d5badc0e3a752d45..2396c7dc0d6ffdb969a5ae91c7d1f04038b8a495 100644 (file)
@@ -24,6 +24,7 @@ src_prepare() {
        eapply "${FILESDIR}/${PN}-2.8.0-prefix.patch"
        eapply "${FILESDIR}/${PN}-2.8.0-blockquote.patch"
        eapply "${FILESDIR}/${PN}-2.8.0-towlower.patch"
+       eapply "${FILESDIR}/${PN}-2.8.0-list-alignment.patch"
 
        eapply_user
        eautoreconf