dev-python/pytools: live ebuild: add py3.5, update git repo URI
authorLouis Sautier <sautier.louis@gmail.com>
Sat, 21 Jan 2017 00:47:52 +0000 (01:47 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 21 Jan 2017 01:41:00 +0000 (02:41 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Closes: https://github.com/gentoo/gentoo/pull/3572

dev-python/pytools/pytools-9999.ebuild

index 7bd405b270a9e57b25694c272d9fae3a7dd90761..f11d02d88c1a9bf0752e75e28811d64367517334 100644 (file)
@@ -1,28 +1,36 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-EAPI=5
+EAPI=6
 
-PYTHON_COMPAT=( python{2_7,3_4} )
-EGIT_MIN_CLONE_TYPE=single
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
 
 inherit distutils-r1 git-r3
 
 DESCRIPTION="A collection of tools missing from the Python standard library"
-HOMEPAGE="http://mathema.tician.de/software/pytools"
-EGIT_REPO_URI="http://git.tiker.net/trees/pytools.git"
+HOMEPAGE="https://mathema.tician.de/software/pytools/"
+EGIT_REPO_URI="https://github.com/inducer/pytools"
 
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS=""
 IUSE="test"
 
+RDEPEND="
+       >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
+       >=dev-python/decorator-3.2.0[${PYTHON_USEDEP}]
+       >=dev-python/numpy-1.6.0[${PYTHON_USEDEP}]
+       >=dev-python/six-1.8.0[${PYTHON_USEDEP}]
+"
 DEPEND="
        >=dev-python/setuptools-0.7.2[${PYTHON_USEDEP}]
-       dev-python/decorator[${PYTHON_USEDEP}]
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-RDEPEND=""
+       test? (
+               ${RDEPEND}
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/pytest-runner[${PYTHON_USEDEP}]
+       )
+"
 
 python_test() {
        py.test -v || die "Tests fail with ${EPYTHON}"