net-dns/dnscrypt-proxy: bump to 2.0.20
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Thu, 14 Mar 2019 02:29:18 +0000 (19:29 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Thu, 14 Mar 2019 02:29:18 +0000 (19:29 -0700)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
net-dns/dnscrypt-proxy/Manifest
net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.20.ebuild [new file with mode: 0644]

index 3272e630fe96bd89b490b0e35e6b9396badc5d9f..df3c2d0035915edb34bfdcae706d19b5da1c3692 100644 (file)
@@ -1 +1,2 @@
 DIST dnscrypt-proxy-2.0.19.tar.gz 3339713 BLAKE2B e65b5ed8243aa6cf471700c6edba6e843fdf6482443335ec74201363657b23a7c6e432318e4de508120b6210cecd02666d97bb62a5f2968ce7d4813518eb3997 SHA512 4501a64717c0f2a9313e9328340e466c9ec325d09ef548f6af9a7855ff3497fb741269a17b397a36e2a120519820378e9f98a6a768a3678ea8144ee4690364f6
+DIST dnscrypt-proxy-2.0.20.tar.gz 2189083 BLAKE2B 0237449e92aaca53078fb9629565b0fde0954e4f4d2ba58ee4840974bbaf9484a7f60dc397d138e8970946b6785490e60f3ddf06dba5636e26996af3328e45db SHA512 6ff9c6806f96328f7b7dad0a5bd56bbb41861cca61882f71a0475cd99a1ee5cd48560eaa078b2fc945b26fe55cc9dc86ddbdaf705d2ae6d783655cdd8d905053
diff --git a/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.20.ebuild b/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.20.ebuild
new file mode 100644 (file)
index 0000000..419d402
--- /dev/null
@@ -0,0 +1,98 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGO_PN="github.com/jedisct1/${PN}"
+
+inherit fcaps golang-build systemd user
+
+if [[ ${PV} == 9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://${EGO_PN}.git"
+else
+       SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="A flexible DNS proxy, with support for encrypted DNS protocols"
+HOMEPAGE="https://github.com/jedisct1/dnscrypt-proxy"
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="pie"
+
+DEPEND=">=dev-lang/go-1.12"
+
+FILECAPS=( cap_net_bind_service+ep usr/bin/dnscrypt-proxy )
+PATCHES=( "${FILESDIR}"/config-full-paths-r10.patch )
+
+pkg_setup() {
+       enewgroup dnscrypt-proxy
+       enewuser dnscrypt-proxy -1 -1 /var/empty dnscrypt-proxy
+}
+
+src_prepare() {
+       default
+       # Create directory structure suitable for building
+       mkdir -p "src/${EGO_PN%/*}" || die
+       # fixes $GOPATH/go.mod exists but should not
+       rm go.mod || die
+       mv "${PN}" "src/${EGO_PN}" || die
+       mv "vendor" "src/" || die
+}
+
+src_configure() {
+       EGO_BUILD_FLAGS="-buildmode=$(usex pie pie default)"
+}
+
+src_install() {
+       dobin dnscrypt-proxy
+
+       insinto /etc/dnscrypt-proxy
+       newins "src/${EGO_PN}"/example-dnscrypt-proxy.toml dnscrypt-proxy.toml
+       doins "src/${EGO_PN}"/example-{blacklist.txt,whitelist.txt}
+       doins "src/${EGO_PN}"/example-{cloaking-rules.txt,forwarding-rules.txt}
+
+       insinto /usr/share/dnscrypt-proxy
+       doins -r "utils/generate-domains-blacklists/."
+
+       newinitd "${FILESDIR}"/dnscrypt-proxy.initd dnscrypt-proxy
+       newconfd "${FILESDIR}"/dnscrypt-proxy.confd dnscrypt-proxy
+       systemd_newunit "${FILESDIR}"/dnscrypt-proxy.service dnscrypt-proxy.service
+       systemd_newunit "${FILESDIR}"/dnscrypt-proxy.socket dnscrypt-proxy.socket
+
+       einstalldocs
+}
+
+pkg_postinst() {
+       fcaps_pkg_postinst
+
+       if ! use filecaps; then
+               ewarn "'filecaps' USE flag is disabled"
+               ewarn "${PN} will fail to listen on port 53"
+               ewarn "please do one the following:"
+               ewarn "1) re-enable 'filecaps'"
+               ewarn "2) change port to > 1024"
+               ewarn "3) configure to run ${PN} as root (not recommended)"
+               ewarn
+       fi
+
+       if systemd_is_booted || has_version sys-apps/systemd; then
+               elog "Using systemd socket activation may cause issues with speed"
+               elog "latency and reliability of ${PN} and is discouraged by upstream"
+               elog "Existing installations advised to disable 'dnscrypt-proxy.socket'"
+               elog "It is disabled by default for new installations"
+               elog "check "$(systemd_get_systemunitdir)/${PN}.service" for details"
+               elog
+
+       fi
+
+       elog "After starting the service you will need to update your"
+       elog "/etc/resolv.conf and replace your current set of resolvers"
+       elog "with:"
+       elog
+       elog "nameserver 127.0.0.1"
+       elog
+       elog "Also see https://github.com/jedisct1/${PN}/wiki"
+}