x11-plugins/wmswallow: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Sat, 17 Aug 2019 17:25:51 +0000 (19:25 +0200)
committerDavid Seifert <soap@gentoo.org>
Sat, 17 Aug 2019 17:25:51 +0000 (19:25 +0200)
Package-Manager: Portage-2.3.71, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild

index c5256efc410a38f713885d3fd1556ce4e4804142..5821727229a1d1b608be3940aac0d071250d4249 100644 (file)
@@ -1,8 +1,9 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
-inherit eutils toolchain-funcs
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
 
 DESCRIPTION="A dock applet to make any application dockable"
 HOMEPAGE="https://www.dockapps.net/wmswallow"
@@ -13,22 +14,32 @@ SLOT="0"
 KEYWORDS="amd64 x86"
 IUSE=""
 
-RDEPEND="x11-libs/libX11
+RDEPEND="
+       x11-libs/libX11
        x11-libs/libXext"
 DEPEND="${RDEPEND}
        x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
 
-S=${WORKDIR}/wmswallow
+S="${WORKDIR}/${PN}"
+PATCHES=( "${FILESDIR}"/${P}-format-security.patch )
 
 src_prepare() {
-       epatch "${FILESDIR}"/${P}-format-security.patch
-       sed -e "s:\${OBJS} -o:\${OBJS} \${LDFLAGS} -o:" \
-               -e "/LIBS/s/-lXext/-lX11 \0/"\
-               -i Makefile || die
+       default
+
+       # the Makefile is a mess, just
+       # rely on implicit rules instead
+       rm Makefile || die
+}
+
+src_configure() {
+       tc-export CC
+       append-cppflags $($(tc-getPKG_CONFIG) --cflags x11 xext)
+       export LDLIBS="$($(tc-getPKG_CONFIG) --libs x11 xext)"
 }
 
 src_compile() {
-       emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" xfree
+       emake wmswallow
 }
 
 src_install() {