media-libs/stimg: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Fri, 13 Dec 2019 00:42:52 +0000 (01:42 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 13 Dec 2019 00:42:52 +0000 (01:42 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
media-libs/stimg/files/stimg-0.1.0-libpng15.patch
media-libs/stimg/stimg-0.1.0.ebuild

index 41ae138f1b1fa612b3fcaf8a6f8e40ef6694ee7b..a1b48ac36e2c8c46c127b6e762d9d4608069bbaa 100644 (file)
@@ -1,6 +1,13 @@
---- src/png.c
-+++ src/png.c
-@@ -102,8 +102,8 @@
+--- a/src/png.c
++++ b/src/png.c
+@@ -1,5 +1,6 @@
+ /* $Id: png.c,v 1.1.1.1 2003/01/30 12:22:26 hito Exp $ */
+ #include <stdio.h>
++#include <string.h>
+ #include <png.h>
+ #include "stimg.h"
+@@ -102,8 +103,8 @@
                0x00,
                NULL);
  
@@ -11,7 +18,7 @@
  
     if (image == NULL) {
        png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp)NULL);
-@@ -112,18 +112,18 @@
+@@ -112,18 +113,18 @@
     }     
  
     row_pointers = png_get_rows(png_ptr, info_ptr);
index 3a7be52b0efc63a167c04657c46b2ed7f7a6beaf..dba7db45095aa2893fe241f119d3d04a54e1d8de 100644 (file)
@@ -1,8 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
-inherit eutils toolchain-funcs
+EAPI=7
+
+inherit toolchain-funcs
 
 DESCRIPTION="Simple and tiny image loading library"
 HOMEPAGE="http://homepage3.nifty.com/slokar/fb/"
@@ -11,26 +12,23 @@ SRC_URI="http://homepage3.nifty.com/slokar/stimg/${P}.tar.gz"
 LICENSE="LGPL-2+ MIT-with-advertising"
 SLOT="0"
 KEYWORDS="alpha amd64 ppc x86"
-IUSE="static-libs"
 
-RDEPEND="media-libs/libpng
-       media-libs/tiff
+RDEPEND="
+       media-libs/libpng:=
+       media-libs/tiff:=
        virtual/jpeg"
 DEPEND="${RDEPEND}"
 
-DOCS=( AUTHORS )
-
-src_prepare() {
-       epatch "${FILESDIR}"/${P}-libpng15.patch
-}
+PATCHES=( "${FILESDIR}"/${P}-libpng15.patch )
 
 src_configure() {
        tc-export CC
-       econf $(use_enable static-libs static)
+       econf --disable-static
 }
 
 src_install() {
        default
-       find "${D}" -name '*.la' -exec rm -f {} +
-       dodoc README.ja
+
+       # no static archives
+       find "${D}" -name '*.la' -delete || die
 }