x11-misc/xfractint: version bump (20.04p14) and EAPI=7
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>
Wed, 17 Apr 2019 16:24:05 +0000 (18:24 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 8 May 2019 22:56:14 +0000 (00:56 +0200)
Closes: https://bugs.gentoo.org/683690
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com>
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
x11-misc/xfractint/Manifest
x11-misc/xfractint/files/xfractint-20.04p09-ldflags.patch
x11-misc/xfractint/xfractint-20.04_p14.ebuild [new file with mode: 0644]

index ebad10714d16c9dd01490df013378df691396768..4a3744b4f1ef9d96a0bd05f4b7fa5d32ba9adb59 100644 (file)
@@ -1 +1,2 @@
 DIST xfractint-20.04p12.tar.gz 1335480 BLAKE2B eef1cd37846865dab9c2616048b26d6a9674799d9317d9f3e92a783e872772c3322826689ec3bf71fc18cef80d4a13a604314d692685bcb268312085d34483fc SHA512 ef233b417ccdff153e53b70f4ac0500be99e9fc6e87360b341640573592320b2485f18fd6426436432d968d33fa41d4862babf193c3b11c480f514a4602bb8f2
+DIST xfractint-20.04p14.tar.gz 1336285 BLAKE2B 946c34551acf131845f1ecf17d4fe82214535627e8ea68d704efcff4b93c525d82f004bde8ae1bac11df8c82caa3bcff4778b2f8dfed1bdb494ba036e62256c5 SHA512 7d13c719f4f4b0680455b9b7f86644928d8145606973d208e5bf0d26b4f7b04ddbf8d2080ea35c872b21e079f1a116f3ef94e9acb36a45d43c16403c473e2acd
index 382bdc6a285cc15a7a155565bc48887c8fae9e20..eb3d92783aae158462015de017cbbe5b5ba7ba8b 100644 (file)
@@ -1,5 +1,5 @@
---- Makefile
-+++ Makefile
+--- a/Makefile
++++ b/Makefile
 @@ -125,7 +125,7 @@
  
  ifeq ($(AS),/usr/bin/nasm)
diff --git a/x11-misc/xfractint/xfractint-20.04_p14.ebuild b/x11-misc/xfractint/xfractint-20.04_p14.ebuild
new file mode 100644 (file)
index 0000000..6b8eb55
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P=${P/_}
+
+DESCRIPTION="A fractal generator"
+HOMEPAGE="https://www.fractint.org"
+SRC_URI="https://www.fractint.org/ftp/current/linux/${MY_P}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+       x11-libs/libXft"
+#      x86? ( dev-lang/nasm )"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}/xfractint-20.04p09-ldflags.patch" )
+
+src_compile() {
+       # Untested, any x86 archteam dev. is allowed to uncomment this.
+       local myasm="foo"
+#      use x86 && myasm="/usr/bin/nasm"
+       emake CC="$(tc-getCC)" AS="${myasm}" OPT="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+       emake DESTDIR="${ED}/usr" STRIP="true" install
+       newenvd "${FILESDIR}"/xfractint.envd 60xfractint
+}
+
+pkg_postinst() {
+       elog "XFractInt requires the FRACTDIR variable to be set in order to start."
+       elog "Please re-login or \`source /etc/profile\` to have this variable set."
+}