media-libs/opencolorio: disable -Werror flag
authorBernd Waibel <waebbl@gmail.com>
Sun, 31 Mar 2019 08:23:27 +0000 (10:23 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 19 May 2019 17:23:38 +0000 (19:23 +0200)
The src/pyglue/CMakeLists.txt has a global -Werror flag set
for unix systems, which let the compile fail. This patch removes this
flag.

Closes: https://bugs.gentoo.org/666696
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Bernd Waibel <waebbl@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/12049
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-libs/opencolorio/files/opencolorio-1.1.0-remove-Werror.patch [new file with mode: 0644]
media-libs/opencolorio/opencolorio-1.1.0-r1.ebuild

diff --git a/media-libs/opencolorio/files/opencolorio-1.1.0-remove-Werror.patch b/media-libs/opencolorio/files/opencolorio-1.1.0-remove-Werror.patch
new file mode 100644 (file)
index 0000000..2814f70
--- /dev/null
@@ -0,0 +1,17 @@
+diff --git a/src/pyglue/CMakeLists.txt b/src/pyglue/CMakeLists.txt
+index a90ca1c..35de89a 100644
+--- a/src/pyglue/CMakeLists.txt
++++ b/src/pyglue/CMakeLists.txt
+@@ -22,9 +22,9 @@ endif()
+ # Process all warnings as errors
+ # Unfortunately Windows still has a warning
+-if(UNIX)
+-    set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror")
+-endif()
++#if(UNIX)
++#    set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror")
++#endif()
+ find_package(PythonLibs)
+ if(NOT PYTHONLIBS_FOUND)
index 2ee8b87912afffbd817e3ce8cff89dadb8ad9061..86efd8a9f584fe3d90d6e0a474bc05eb53d71b5b 100644 (file)
@@ -45,6 +45,7 @@ PATCHES=(
        "${FILESDIR}/${P}-use-GNUInstallDirs-and-fix-cmake-install-location.patch"
        "${FILESDIR}/${P}-remove-building-of-bundled-programs.patch"
        "${FILESDIR}/${P}-yaml-cpp-0.6.patch"
+       "${FILESDIR}/${P}-remove-Werror.patch"
 )
 
 pkg_setup() {