net-proxy/squid: Fix 32-bit build
authorSam James (sam_c) <sam@cmpct.info>
Fri, 8 May 2020 03:00:53 +0000 (03:00 +0000)
committerMikle Kolyada <zlogene@gentoo.org>
Mon, 18 May 2020 13:43:53 +0000 (16:43 +0300)
Links against libatomic on 32-bit non-x86 arches.

Bug: https://bugs.gentoo.org/719662
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Sam James (sam_c) <sam@cmpct.info>
Closes: https://github.com/gentoo/gentoo/pull/15705
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
net-proxy/squid/squid-4.11.ebuild

index b0fc4013b7d9f2f69f12755be94728fffdfe4564..978bb9b39222e7780d3f482c0d5800ea1bbfa1cf 100644 (file)
@@ -5,7 +5,7 @@ EAPI=7
 
 WANT_AUTOMAKE="1.15"
 
-inherit autotools linux-info pam toolchain-funcs
+inherit autotools flag-o-matic linux-info pam toolchain-funcs
 
 DESCRIPTION="A full-featured web proxy cache"
 HOMEPAGE="http://www.squid-cache.org/"
@@ -173,6 +173,9 @@ src_configure() {
        # https://bugs.squid-cache.org/show_bug.cgi?id=4224
        tc-is-cross-compiler && export squid_cv_gnu_atomics=no
 
+       # Bug #719662
+       (use ppc || use arm || use hppa) && append-libs -latomic
+
        econf \
                --sysconfdir=/etc/squid \
                --libexecdir=/usr/libexec/squid \