dev-python/google-apitools: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 11 May 2020 16:50:13 +0000 (18:50 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 11 May 2020 17:33:03 +0000 (19:33 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/google-apitools/Manifest
dev-python/google-apitools/google-apitools-0.5.30.ebuild [deleted file]

index 7db71160bda5613cef81ee12cc37776e3e7055d1..3694ed735d811ab4478fb80baffb9c10ef48d842 100644 (file)
@@ -1,2 +1 @@
-DIST google-apitools-0.5.30.tar.gz 363524 BLAKE2B ed8477c85911f5855a449abe81b465635d3cc4e08d2915de5e882608e634f3dd9ffdda929bd8b25eb3daa5922851aa9304ffe07778cdf3a3aa629e215633515a SHA512 2dffffada829b9b962c64aab22b19cd227981819128c34f3e32515ee599297b3d5e8c97152d954110c2ef27c02737d3c30c785840b9f9767068688f62dc0b5c7
 DIST google-apitools-0.5.30_p20200507.tar.gz 365250 BLAKE2B 58d52016775b387b494d8b5897886f059fe74a360098f6527089039469d4d4e3c0d9ec63a12be1215741fd15a1a03e2204f54ace7c9eaf8bbdc8236c9c1fe576 SHA512 94879360c5de3d7405b7377b2baf0fa303c1b0bace56cf75d203b0a509ac028e1d3208a82ba08de7d17e4e26571c9b8601cb07e6897b658eeede9d06fd384fe3
diff --git a/dev-python/google-apitools/google-apitools-0.5.30.ebuild b/dev-python/google-apitools/google-apitools-0.5.30.ebuild
deleted file mode 100644 (file)
index 7b8566a..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library to manipulate Google APIs"
-HOMEPAGE="https://github.com/google/apitools"
-SRC_URI="https://github.com/google/apitools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
-       >=dev-python/fasteners-0.14[${PYTHON_USEDEP}]
-       >=dev-python/oauth2client-1.5.2[${PYTHON_USEDEP}]
-       >=dev-python/six-1.12.0[${PYTHON_USEDEP}]
-       >=dev-python/python-gflags-3.1.2[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       >=dev-python/setuptools-18.5[${PYTHON_USEDEP}]
-       test? (
-               dev-python/nose[${PYTHON_USEDEP}]
-               >=dev-python/unittest2-0.5.1[${PYTHON_USEDEP}]
-               >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
-       )"
-
-S="${WORKDIR}/apitools-${PV}"
-
-PATCHES=(
-       "${FILESDIR}/google-apitools-0.5.30-skip-enum-test-on-new-python.patch"
-)
-
-python_test() {
-       nosetests -v || die "tests failed with ${EPYTHON}"
-}