net-libs/libtelnet: Update live ebuild
authorDavid Seifert <soap@gentoo.org>
Sun, 16 Jun 2019 17:25:13 +0000 (19:25 +0200)
committerDavid Seifert <soap@gentoo.org>
Sun, 16 Jun 2019 17:25:13 +0000 (19:25 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: David Seifert <soap@gentoo.org>
net-libs/libtelnet/libtelnet-9999.ebuild

index aae3c462a1cc9e493d89db505bb99027b7ac4728..620355b68c920c33556e0322df6ab3f4b5c1af16 100644 (file)
@@ -1,33 +1,24 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
-inherit eutils autotools
-DESCRIPTION="Simple RFC-complient TELNET implementation as a C library"
-HOMEPAGE="https://github.com/seanmiddleditch/libtelnet"
+EAPI=7
+
+inherit cmake-utils
 
-if [ ${PV} = 9999 ]; then
-       KEYWORDS=""
-       EGIT_REPO_URI="https://github.com/seanmiddleditch/${PN}.git"
-       inherit git-2
-       DEPEND="dev-vcs/git"
-       S="${WORKDIR}/${PN}-master"
+if [[ ${PV} == *9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/seanmiddleditch/libtelnet.git"
 else
+       SRC_URI="https://github.com/seanmiddleditch/libtelnet/archive/${PV}.tar.gz -> ${P}.tar.gz"
        KEYWORDS="~x86 ~amd64"
-       SRC_URI="https://github.com/seanmiddleditch/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
 fi
 
-WANT_AUTOMAKE=1.11
-DEPEND="${DEPEND} sys-devel/automake:${WANT_AUTOMAKE}"
+DESCRIPTION="Simple RFC-complient TELNET implementation as a C library"
+HOMEPAGE="https://github.com/seanmiddleditch/libtelnet"
+
 LICENSE="public-domain"
 SLOT="0"
 IUSE=""
-RDEPEND=""
 
-src_prepare() {
-       _elibtoolize
-       eaclocal
-       eautoconf
-       eautoheader
-       eautomake
-}
+# needed unconditionally for man pages
+DEPEND="app-doc/doxygen"