dev-util/meson: disable some additional unit tests
authorMike Gilbert <floppym@gentoo.org>
Mon, 25 May 2020 21:34:51 +0000 (17:34 -0400)
committerMike Gilbert <floppym@gentoo.org>
Mon, 25 May 2020 21:43:16 +0000 (17:43 -0400)
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
dev-util/meson/meson-0.54.2.ebuild
dev-util/meson/meson-9999.ebuild

index 2ef1f787f28b35905c252b5488871d692d5e5d17..4945b8d2278e629e07c410620860edccd2856346 100644 (file)
@@ -39,13 +39,23 @@ PATCHES=(
 )
 
 python_prepare_all() {
-       # ASAN and sandbox both want control over LD_PRELOAD
-       # https://bugs.gentoo.org/673016
-       sed -i -e 's/test_generate_gir_with_address_sanitizer/_&/' run_unittests.py || die
+       local disable_unittests=(
+               # ASAN and sandbox both want control over LD_PRELOAD
+               # https://bugs.gentoo.org/673016
+               -e 's/test_generate_gir_with_address_sanitizer/_&/'
 
-       # ASAN is unsupported on some targets
-       # https://bugs.gentoo.org/692822
-       sed -i -e 's/test_pch_with_address_sanitizer/_&/' run_unittests.py || die
+               # ASAN is unsupported on some targets
+               # https://bugs.gentoo.org/692822
+               -e 's/test_pch_with_address_sanitizer/_&/'
+
+               # https://github.com/mesonbuild/meson/issues/7203
+               -e 's/test_templates/_&/'
+
+               # Broken due to python2 wrapper
+               -e 's/test_python_module/_&/'
+       )
+
+       sed -i "${disable_unittests[@]}" run_unittests.py || die
 
        # Broken due to python2 script created by python_wrapper_setup
        rm -r "test cases/frameworks/1 boost" || die
index 053a12bbeb2fd3f7e0d5dfb1227b5c56825d44c2..5cd9c5f13bb2bd1d20831f3e18dbfdd4a3225578 100644 (file)
@@ -35,13 +35,23 @@ DEPEND="
 "
 
 python_prepare_all() {
-       # ASAN and sandbox both want control over LD_PRELOAD
-       # https://bugs.gentoo.org/673016
-       sed -i -e 's/test_generate_gir_with_address_sanitizer/_&/' run_unittests.py || die
+       local disable_unittests=(
+               # ASAN and sandbox both want control over LD_PRELOAD
+               # https://bugs.gentoo.org/673016
+               -e 's/test_generate_gir_with_address_sanitizer/_&/'
 
-       # ASAN is unsupported on some targets
-       # https://bugs.gentoo.org/692822
-       sed -i -e 's/test_pch_with_address_sanitizer/_&/' run_unittests.py || die
+               # ASAN is unsupported on some targets
+               # https://bugs.gentoo.org/692822
+               -e 's/test_pch_with_address_sanitizer/_&/'
+
+               # https://github.com/mesonbuild/meson/issues/7203
+               -e 's/test_templates/_&/'
+
+               # Broken due to python2 wrapper
+               -e 's/test_python_module/_&/'
+       )
+
+       sed -i "${disable_unittests[@]}" run_unittests.py || die
 
        # Broken due to python2 script created by python_wrapper_setup
        rm -r "test cases/frameworks/1 boost" || die