dev-python/hacking: 1.1.0 removed
authorMatthew Thode <prometheanfire@gentoo.org>
Sun, 26 Jan 2020 21:45:37 +0000 (15:45 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Sun, 26 Jan 2020 21:46:22 +0000 (15:46 -0600)
Closes: https://bugs.gentoo.org/643616
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/hacking/Manifest
dev-python/hacking/hacking-1.1.0.ebuild [deleted file]

index da8ad358afff7e401f0bb5c84cf1342facb69d55..d716e3067de07e6f7cf061d4489411caadf86a85 100644 (file)
@@ -1,2 +1 @@
-DIST hacking-1.1.0.tar.gz 55620 BLAKE2B 6a6f30ef8a1eef3aa1b1b630dd43e1d2e9adff1623d8db19a545f186f60ce367e4b820582893e6444b7d58573b4a70a47a30cdc8d2ce1202666cf6e1b0e7456f SHA512 d326995976c04469c9d164ff31d02471346af715730d97fee23261988100156c4598ea8968cb483e8f386ee3f94a6bdffb5f67d8a7dfc238f4607fb7fe09e128
 DIST hacking-2.0.0.tar.gz 53296 BLAKE2B 50606d700c324acc8695499ee97cd592b051fe0cfc020efdfe7bf82b44d2f6ac858ed2f923ea08343066820c7da1686aa0b172bbab541cc564dc5ecc016cfac6 SHA512 d44d62f694c79af4c2044e745b140f0582fb5a6bbfa8050d45b17e8cb354198e8eac3a06586cf96d516844bb079d429d73ce9755a23e256857c4de19aca7ffe3
diff --git a/dev-python/hacking/hacking-1.1.0.ebuild b/dev-python/hacking/hacking-1.1.0.ebuild
deleted file mode 100644 (file)
index 806a349..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="A client for the OpenStack Nova API"
-HOMEPAGE="https://github.com/openstack-dev/hacking"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~hppa ~ppc64 ~s390 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-python/flake8-2.6.0[${PYTHON_USEDEP}]
-       <dev-python/flake8-2.7.0[${PYTHON_USEDEP}]
-       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
-       !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
-       test? (
-               >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
-               !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
-               >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
-               >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
-               >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
-               >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
-               >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
-               >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
-               ${RDEPEND}
-       )
-       doc? (
-               >=dev-python/sphinx-1.7.0[${PYTHON_USEDEP}]
-               >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
-               >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
-       )"
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile_all() {
-       use doc && sphinx-build -b html -c doc/source/ doc/source/ doc/source/html
-}
-
-python_test() {
-       testr init || die "testr init died"
-       testr run || die "testsuite failed under ${EPYTHON}"
-       flake8 "${PN}"/tests || die "flake8 drew error on a run over ${PN}/tests folder"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/source/html/. )
-       distutils-r1_python_install_all
-}