dev-python/thunarx-python: remove obsolete xfconf.eclass, migrate to EAPI6
authorDenis Dupeyron <calchan@gentoo.org>
Mon, 27 Nov 2017 20:48:34 +0000 (20:48 +0000)
committerDenis Dupeyron <calchan@gentoo.org>
Mon, 27 Nov 2017 20:48:34 +0000 (20:48 +0000)
Package-Manager: Portage-2.3.13, Repoman-2.3.3

dev-python/thunarx-python/thunarx-python-0.3.0-r2.ebuild [new file with mode: 0644]

diff --git a/dev-python/thunarx-python/thunarx-python-0.3.0-r2.ebuild b/dev-python/thunarx-python/thunarx-python-0.3.0-r2.ebuild
new file mode 100644 (file)
index 0000000..437e445
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Python bindings for the Thunar file manager"
+HOMEPAGE="https://goodies.xfce.org/projects/bindings/thunarx-python"
+SRC_URI="mirror://xfce/src/bindings/${PN}/0.3/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+       x11-libs/gtk+:2
+       dev-libs/glib:2
+       >=dev-python/pygobject-2.16:2[${PYTHON_USEDEP}]
+       dev-python/pygtk:2[${PYTHON_USEDEP}]
+       >=xfce-base/thunar-1.1.0"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_install() {
+       default
+
+       find "${D}" -name '*.la' -delete || die
+}