dev-util/quilt: Dop old
authorMikle Kolyada <zlogene@gentoo.org>
Sun, 20 Oct 2019 08:58:11 +0000 (11:58 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Sun, 20 Oct 2019 08:58:23 +0000 (11:58 +0300)
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
dev-util/quilt/Manifest
dev-util/quilt/files/quilt-0.50-no-graphviz.patch [deleted file]
dev-util/quilt/quilt-0.50.ebuild [deleted file]

index f76cb68f8b3a3a3ef084682c2f0ead376ffb0240..380e0647ab0632af2047fdb09bf19a1807ea385c 100644 (file)
@@ -1,2 +1 @@
-DIST quilt-0.50.tar.gz 452769 BLAKE2B 5d466d1feca8a1f702db9d5f2bb4340331d06e413992fc8f30111d48daf71f560d60444ddb49cc06096552f32feb44cfd369f370222f574cea4664f4324d04fa SHA512 c6258872bc591b35e93ba09cc17b4954696faf391aff71b7789cc8cc58c4c54e51b605896937bd1aa54545eed6bf1e9b70352ad9b643f869154e6953c0340365
 DIST quilt-0.66.tar.gz 413069 BLAKE2B 41201d54cb26d4761413365fe19b65bd6971ada1e69198d2edbc346df6a3060ff3af4d80551d68ab4ffe003183bc0a28515ce1d070db95f2b1a04a0680ac4fb2 SHA512 c2cb75c0937612e1e0da25b713acf629b6b5aacbd8254d8bd17220b63c7b8ca996cd9d0315a32d67d54a4a7dc01b212cdda33afaacf3db063da757f1973306f4
diff --git a/dev-util/quilt/files/quilt-0.50-no-graphviz.patch b/dev-util/quilt/files/quilt-0.50-no-graphviz.patch
deleted file mode 100644 (file)
index 04e0d7d..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-Index: b/Makefile.in
-===================================================================
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -82,8 +82,7 @@ QUILT :=     $(QUILT_IN)
- SRC +=                $(QUILT_SRC:%=quilt/%)
- DIRT +=               $(QUILT_IN:%=quilt/%)
--SCRIPTS_IN := patchfns parse-patch inspect dependency-graph edmail    \
--              remove-trailing-ws
-+SCRIPTS_IN := patchfns parse-patch inspect edmail remove-trailing-ws
- SCRIPTS_SRC :=        $(SCRIPTS_IN:%=%.in)
- SCRIPTS :=    $(SCRIPTS_IN)
-Index: b/bash_completion
-===================================================================
---- a/bash_completion
-+++ b/bash_completion
-@@ -95,7 +95,7 @@ _quilt_completion()
-     prev=${COMP_WORDS[COMP_CWORD-1]}
-     # quilt sub commands 
--    cmds='add annotate applied delete diff edit files fold fork graph \
-+    cmds='add annotate applied delete diff edit files fold fork \
-           grep header import mail new next patches pop previous push refresh \
-         remove rename revert series setup snapshot top unapplied'
-@@ -189,19 +189,6 @@ _quilt_completion()
-               ;;
-          esac
-          ;;
--      graph)
--         case $prev in
--           -T)
--              COMPREPLY=( $( compgen -W "ps" -- $cur ) )
--              ;;
--           --edge-labels)
--              COMPREPLY=( $( compgen -W "files" -- $cur ) )
--              ;;
--           *)
--              COMPREPLY=( $( compgen -W "-T -h --all --reduce --lines --edge-labels $(quilt applied 2>/dev/null)" -- $cur ) )
--              ;;
--         esac
--         ;;
-       grep)
-          _longopt grep
-          COMPREPLY=( ${COMPREPLY[@]:-} $( compgen -W "-h" -- $cur ) )
diff --git a/dev-util/quilt/quilt-0.50.ebuild b/dev-util/quilt/quilt-0.50.ebuild
deleted file mode 100644 (file)
index d5d270c..0000000
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit bash-completion-r1 eutils
-
-DESCRIPTION="quilt patch manager"
-HOMEPAGE="https://savannah.nongnu.org/projects/quilt"
-SRC_URI="https://savannah.nongnu.org/download/quilt/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm ppc ppc64 sparc x86"
-IUSE="emacs graphviz"
-
-RDEPEND="sys-apps/ed
-       dev-util/diffstat
-       graphviz? ( media-gfx/graphviz )
-       >=sys-apps/coreutils-8.5"
-
-PDEPEND="emacs? ( app-emacs/quilt-el )"
-
-pkg_setup() {
-       use graphviz && return 0
-       echo
-       elog "If you intend to use the folding functionality (graphical illustration of the"
-       elog "patch stack) then you'll need to remerge this package with USE=graphviz."
-       echo
-       epause 5
-}
-
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-
-       # Add support for USE=graphviz
-       use graphviz || epatch "${FILESDIR}/${P}-no-graphviz.patch"
-
-       # Some tests are somewhat broken while being run from within portage, work
-       # fine if you run them manually
-       rm "${S}"/test/delete.test "${S}"/test/mail.test
-}
-
-src_install() {
-       emake BUILD_ROOT="${D}" install || die "make install failed"
-
-       rm -rf "${D}"/usr/share/doc/${P}
-       dodoc AUTHORS TODO quilt.changes doc/README doc/README.MAIL \
-               doc/quilt.pdf
-
-       rm -rf "${D}"/etc/bash_completion.d
-       newbashcomp bash_completion ${PN}
-
-       # Remove the compat symlinks
-       rm -rf "${D}"/usr/share/quilt/compat
-
-       # Remove Emacs mode; newer version is in app-emacs/quilt-el, bug 247500
-       rm -rf "${D}"/usr/share/emacs
-}