Revert "dev-python/pycparser: trick tests into using CPP variable"
authorMike Gilbert <floppym@gentoo.org>
Tue, 19 May 2020 19:46:09 +0000 (15:46 -0400)
committerMike Gilbert <floppym@gentoo.org>
Tue, 19 May 2020 19:47:35 +0000 (15:47 -0400)
This reverts commit f3af4c3be7962780f471641f0d8d2f6b9c335cdc.

Bug: https://bugs.gentoo.org/719934
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
dev-python/pycparser/pycparser-2.20.ebuild

index 4227f14e0bf5bbe1f52bea10984aca7cfa3591bf..4b222c379ee4ce9dd33c2fc2f4ad179f7b401050 100644 (file)
@@ -5,7 +5,7 @@ EAPI=7
 
 PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
 
-inherit distutils-r1 toolchain-funcs
+inherit distutils-r1
 
 DESCRIPTION="C parser and AST generator written in Python"
 HOMEPAGE="https://github.com/eliben/pycparser"
@@ -41,20 +41,9 @@ python_compile() {
 }
 
 python_test() {
-       # Trick the tests into using CPP variable
-       # https://bugs.gentoo.org/719934
-       local CPP="$(tc-getCPP)"
-       mkdir -p "${T}"/bin || die
-       cat > "${T}"/bin/cpp <<-EOF || die
-       #!/bin/sh
-       exec ${CPP} "\$@"
-       EOF
-       chmod +x "${T}"/bin/cpp || die
-       local -x PATH="${T}/bin:${PATH}"
-
        # change workdir to avoid '.' import
        cd tests || die
-       ${EPYTHON} -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+       "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
 }
 
 python_install() {