dev-python/requests_download: New package
authorPatrick McLean <chutzpah@gentoo.org>
Sat, 7 Dec 2019 20:48:19 +0000 (12:48 -0800)
committerPatrick McLean <chutzpah@gentoo.org>
Sat, 7 Dec 2019 21:55:29 +0000 (13:55 -0800)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/requests_download/Manifest [new file with mode: 0644]
dev-python/requests_download/metadata.xml [new file with mode: 0644]
dev-python/requests_download/requests_download-0.1.2.ebuild [new file with mode: 0644]

diff --git a/dev-python/requests_download/Manifest b/dev-python/requests_download/Manifest
new file mode 100644 (file)
index 0000000..8951ccf
--- /dev/null
@@ -0,0 +1 @@
+DIST requests_download-0.1.2.tar.gz 2584 BLAKE2B c6f2eb7a182e0f42ccb7b603dec47a077b1b946bfa93968972dce5267c7c51fa8c4158e15cd35621cbe229e12f6644db9734e52439796d8d8411be16a38e1e9a SHA512 99d4b275200c88befd2730d17a3329c8cbb155fa5cf9600a7466e8ab109f999a9fc9b8c668aa3b389bc2a3deb33b8a3fd390270d71f04bb0a8f998da67cfde82
diff --git a/dev-python/requests_download/metadata.xml b/dev-python/requests_download/metadata.xml
new file mode 100644 (file)
index 0000000..2d3a29f
--- /dev/null
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="person">
+    <email>chutzpah@gentoo.org</email>
+    <name>Patrick McLean</name>
+  </maintainer>
+  <upstream>
+    <remote-id type="pypi">requests_download</remote-id>
+    <remote-id type="github">takluyver/requests_download</remote-id>
+  </upstream>
+</pkgmetadata>
diff --git a/dev-python/requests_download/requests_download-0.1.2.ebuild b/dev-python/requests_download/requests_download-0.1.2.ebuild
new file mode 100644 (file)
index 0000000..231d387
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="A convenient function to download to a file using requests"
+HOMEPAGE="https://github.com/takluyver/requests_download https://pypi.org/project/requests_download/"
+SRC_URI="https://github.com/takluyver/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"
+
+# there are no tests upstream
+RESTRICT="test"
+
+DOCS=( README.rst )
+
+python_prepare_all() {
+       printf -- "from setuptools import setup\nsetup(name='%s',version='%s',py_modules=['%s'])" \
+               "${PN}" "${PV}" "${PN}" > setup.py || die
+
+       distutils-r1_python_prepare_all
+}