app-emacs/csharp-mode: Bump to version 0.9.2.
authorUlrich Müller <ulm@gentoo.org>
Thu, 17 Oct 2019 13:17:22 +0000 (15:17 +0200)
committerUlrich Müller <ulm@gentoo.org>
Thu, 17 Oct 2019 13:19:09 +0000 (15:19 +0200)
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
app-emacs/csharp-mode/Manifest
app-emacs/csharp-mode/csharp-mode-0.9.2.ebuild [new file with mode: 0644]

index 36a067bf8af66fd9a4c4c661c9ca1db7f771d2f7..33cc7a7f37bb9d5a4419cb3f71eb4a9453fdb58f 100644 (file)
@@ -1 +1,2 @@
 DIST csharp-mode-0.9.0.tar.gz 50453 BLAKE2B ed4b6ba56a9283687db332749510dcb63cc4bfc35687979cabae48b76d9e36598c88ff43f2920ca5272b56833d5cadd6602b47be21d88a7cd25d6ecb0e748493 SHA512 81661d98acdf03e01caf3b9388da8571e78402b8914755b223a38a723457a988201adcaf7b5b825c4e0126ad5e7628063f85dd4e60ee272102a5f1509f9446ef
+DIST csharp-mode-0.9.2.tar.gz 52389 BLAKE2B 897d8bf3b9e0963647071628af874a77f7181592fe21f2094082c807cb33d26e43825f36cefcd100ad46dea67d217f99ec89e5f3e2c94a639553d7334ff39bc8 SHA512 da4e0aff63600c01d1571fea19d7892af1c3bd5366b97a1d9321853db7d52f04431f0c7c16371a0ef0f8296ccbf2baf0890ceb67e48a9159faf6fd6d10cb49ab
diff --git a/app-emacs/csharp-mode/csharp-mode-0.9.2.ebuild b/app-emacs/csharp-mode/csharp-mode-0.9.2.ebuild
new file mode 100644 (file)
index 0000000..d2dad16
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="A derived Emacs mode implementing most of the C# rules"
+HOMEPAGE="https://github.com/josteink/csharp-mode"
+SRC_URI="https://github.com/josteink/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+       elisp-install ${PN} csharp-mode.el{,c}
+       elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+       dodoc README.org
+}