dev-ros/roslaunch: Bump to 1.14.3.
authorAlexis Ballier <aballier@gentoo.org>
Tue, 7 Aug 2018 13:54:00 +0000 (15:54 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 7 Aug 2018 15:48:49 +0000 (17:48 +0200)
Package-Manager: Portage-2.3.44, Repoman-2.3.10

dev-ros/roslaunch/Manifest
dev-ros/roslaunch/roslaunch-1.14.3.ebuild [new file with mode: 0644]

index 4bc29c3999ee6eb165f2bf39e30f694aebaff184..ccd939b014023e64357f32d482c75dd119fdf328 100644 (file)
@@ -5,3 +5,4 @@ DIST ros_comm-1.13.4.tar.gz 1013412 BLAKE2B 0f5a33ae9c5c3bd3c04e26903c4ee7dff2d3
 DIST ros_comm-1.13.5.tar.gz 1027857 BLAKE2B ed2611179bc7f84bf0b9cde1336474a3bc4c3980ebf97241910123abd430a48ae0636a6ddfb6c191bea2905454644c7ec340e26049d8faddca39783bef13d60b SHA512 91af2de897851061eda140d6c96ec88171f1fd1cd7549b6df1ac570e066603c7bb721a58cb19487657387753433d67ad22421408a237d1ffb5ea580c0cf3eeb3
 DIST ros_comm-1.13.6.tar.gz 1047870 BLAKE2B 874e31faa1a6a77292dab4b7fa64ed13a1f1f63f76512ea351e53bd14ce87662cea5c648e48c3c16668104129cc5eb172bc8f381516bdba676c7212f1acbaaf9 SHA512 382e81847141ab95462fc84a8215b945af995d29f9c0d507665e22faaf79aee9789950546ca7737bd40059f3ed1ecd284ff11bd3e6f1732f3c47a433c5d25155
 DIST ros_comm-1.14.2.tar.gz 1044745 BLAKE2B 1a5d47a4c6682c7a629d9d84be121a5eafcfc16621dec9a9ab9b57c2c7f9070f0007e15492ee44d86e1879351fae20bb9a759093424dd22ae7d44ae0f28e00e1 SHA512 8cece09572dc6b94a42eb49537cbcddbb954f70df01dc7ac9bd8aba17f53207b86afd8ccff81d929eca33bb9642ad7c530835d3f43471de497611940edae4777
+DIST ros_comm-1.14.3.tar.gz 1045287 BLAKE2B c079983aa730e70028d1bf2c365d01d99ce09ced0c0f6443b18f9d0fb83715f6af4b313d6db4eb99dcc10052c81fa3e6560e7b3591b2fbe14b9ec20fac24babe SHA512 52df24f10f476697ee6fa340da354b45431f35018a25e2674dc9306f175929a4b0368753503ea143f87aeb4945a2e67c37f83d833f54b53f9a76a81022c280a3
diff --git a/dev-ros/roslaunch/roslaunch-1.14.3.ebuild b/dev-ros/roslaunch/roslaunch-1.14.3.ebuild
new file mode 100644 (file)
index 0000000..4a273f6
--- /dev/null
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit ros-catkin user
+
+DESCRIPTION="Tool for easily launching multiple ROS nodes"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/roslib[${PYTHON_USEDEP}]
+       dev-python/rospkg[${PYTHON_USEDEP}]
+       dev-ros/rosclean[${PYTHON_USEDEP}]
+       dev-python/pyyaml[${PYTHON_USEDEP}]
+       dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+       dev-ros/rosparam[${PYTHON_USEDEP}]
+       dev-ros/rosmaster[${PYTHON_USEDEP}]
+       dev-ros/rosout
+"
+DEPEND="${RDEPEND}
+       test? (
+               dev-util/rosdep[${PYTHON_USEDEP}]
+               dev-python/nose[${PYTHON_USEDEP}]
+               dev-ros/test_rosmaster
+       )"
+PATCHES=( "${FILESDIR}/timeout.patch" )
+
+src_test() {
+       rosdep update
+       ros-catkin_src_test
+}
+
+src_install() {
+       ros-catkin_src_install
+
+       dodir /etc/ros
+       sed -e "s/@PKG_VERSION@/${PV}/" "${FILESDIR}/roscore.xml.in" > "${ED}/etc/ros/roscore.xml" || die
+
+       newinitd "${FILESDIR}/roscore.initd" roscore
+       newconfd "${FILESDIR}/roscore.confd" roscore
+
+       newinitd "${FILESDIR}/roslaunch.initd" roslaunch
+       newconfd "${FILESDIR}/roslaunch.confd" roslaunch
+
+       doenvd "${FILESDIR}/40roslaunch"
+
+       # Needed by test_roslaunch
+       insinto /usr/share/${PN}
+       doins test/xml/noop.launch
+}
+
+pkg_preinst() {
+       enewgroup ros
+       enewuser ros -1 -1 /home/ros ros
+}