kde-apps/libkdcraw: Fix build with >=media-libs/libraw-0.16.1
authorJohannes Huber <johu@gentoo.org>
Tue, 18 Aug 2015 20:11:02 +0000 (22:11 +0200)
committerJohannes Huber <johu@gentoo.org>
Tue, 18 Aug 2015 20:11:16 +0000 (22:11 +0200)
Revision bump adds upstream patch by Gilles Caulier <caulier.gilles@gmail.com>.

Gentoo-Bug: 555646
Reported-by: Oleg <oleg@funtoo.org>
Acked-by: Robin Johnson <robbat2@gentoo.org>
Package-Manager: portage-2.2.20.1

kde-apps/libkdcraw/files/libkdcraw-4.14.3-libraw-0.16.1.patch [new file with mode: 0644]
kde-apps/libkdcraw/libkdcraw-4.14.3-r1.ebuild [new file with mode: 0644]

diff --git a/kde-apps/libkdcraw/files/libkdcraw-4.14.3-libraw-0.16.1.patch b/kde-apps/libkdcraw/files/libkdcraw-4.14.3-libraw-0.16.1.patch
new file mode 100644 (file)
index 0000000..a55ef87
--- /dev/null
@@ -0,0 +1,18 @@
+commit 46898ec97a0462eb08a5b6d09999450a86b27aae
+Author: Gilles Caulier <caulier.gilles@gmail.com>
+Date:   Thu May 14 22:54:16 2015 +0200
+
+libraw 0.16.1 needs C++ exceptions rules while compilation
+BUGS: 347728
+FIXED-IN: 4.11.0
+--- libkdcraw/CMakeLists.txt
++++ libkdcraw/CMakeLists.txt
+@@ -22,6 +22,8 @@
+ #
+ # ============================================================
++add_definitions (${KDE4_ENABLE_EXCEPTIONS})
++
+ CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/version.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/version.h)
+ SET(kdcraw_LIB_SRCS kdcraw.cpp
diff --git a/kde-apps/libkdcraw/libkdcraw-4.14.3-r1.ebuild b/kde-apps/libkdcraw/libkdcraw-4.14.3-r1.ebuild
new file mode 100644 (file)
index 0000000..344cabb
--- /dev/null
@@ -0,0 +1,18 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit kde4-base
+
+DESCRIPTION="KDE digital camera raw image library wrapper"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+       >=media-libs/libraw-0.16_beta1-r1:=
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-libraw-0.16.1.patch" )