sci-electronics/systemc: drop old EAPI
authorAaron Bauman <bman@gentoo.org>
Wed, 13 Nov 2019 19:41:44 +0000 (14:41 -0500)
committerAaron Bauman <bman@gentoo.org>
Wed, 13 Nov 2019 19:58:43 +0000 (14:58 -0500)
Signed-off-by: Aaron Bauman <bman@gentoo.org>
sci-electronics/systemc/Manifest
sci-electronics/systemc/systemc-2.3.0-r1.ebuild [deleted file]

index d9a0143123e91d6f60031b667dc89fdcea96d08f..00af93db1ea91a9f2bb13f1958ffeab7584d701f 100644 (file)
@@ -1,2 +1 @@
-DIST systemc-2.3.0a.tar.gz 7084178 BLAKE2B c2bc70a3b0a0759da028cb89d53ae697c28fec62431c3ec3de2fabd52164352cc26033643120ff99329409db2d0b5438648896cde1267da2e9514cc7800ee097 SHA512 3af3c0c96a95ee75e0a6c046fdd94ee822b8fbbc1c79e7bbf9b905e7a2d3689282e6d97cfa56c93094155d79126e74f052c0f0e12f31bf4321b28a03aae347ab
 DIST systemc-2.3.1a.tar.gz 7050669 BLAKE2B eb080ba177ada7fcd816134e62e6461da59a186cd5d1a14627d69d425f72becd587ef7d31e9e48af76cf54f92ccf83f38a079e5598b4fe2e6b349dc4ec74f640 SHA512 cd52eb6e413c8b852e19c8387766eacbddf85e9b2f4d137f3d82d0d4025f13a44216a2e6cacf7b9e2b972584912a4a1c75cdb37a568330ce66a6bf909ca1b723
diff --git a/sci-electronics/systemc/systemc-2.3.0-r1.ebuild b/sci-electronics/systemc/systemc-2.3.0-r1.ebuild
deleted file mode 100644 (file)
index 0807538..0000000
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils multilib toolchain-funcs autotools-utils
-MY_P="${P}a"
-
-DESCRIPTION="A C++ based modeling platform for VLSI and system-level co-design"
-HOMEPAGE="http://accellera.org/community/systemc"
-SRC_URI="http://accellera.org/images/downloads/standards/${PN}/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-IUSE="doc static-libs"
-KEYWORDS="~amd64 ~x86"
-
-RESTRICT="test"
-
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
-       # drop compiler check to enable use of CXX
-       epatch "${FILESDIR}"/${P}-config.patch
-
-       sed -i -e "s:OPT_CXXFLAGS=\"-O3\":OPT_CXXFLAGS=\"\":g" configure.in || die "Patching configure.in failed"
-
-       sed -i -e "s:lib-\$(TARGET_ARCH):$(get_libdir):g" $(find . -name Makefile.am) || die "Patching Makefile.am failed"
-
-       # respect DESTDIR
-       sed -i -e "s:\$(prefix):\$(DESTDIR)\$(prefix):g" $(find . -name Makefile.am) || die "Patching Makefile.am failed"
-
-       eautoreconf
-
-       sed -i -e "s:\$(DESTDIR)\$(libdir):\$(libdir):g" src/sysc/Makefile.in || die
-
-       for sfile in src/sysc/qt/md/*.s ; do
-               sed -i -e '$a \
-#if defined(__linux__) && defined(__ELF__) \
-.section .note.GNU-stack,"",%progbits \
-#endif' "${sfile}" || die "Patching ${sfile} failed"
-       done
-}
-
-src_configure() {
-       econf $(use_enable static-libs static) CXX=$(tc-getCXX)
-}
-
-src_compile() {
-       cd src
-       default
-}
-
-src_install() {
-       dodoc AUTHORS ChangeLog INSTALL NEWS README RELEASENOTES
-       use doc && dodoc -r docs/*
-       cd src
-       autotools-utils_src_install
-}
-
-pkg_postinst() {
-       elog "If you want to run the examples, you need to :"
-       elog "    tar xvfz ${PORTAGE_ACTUAL_DISTDIR}/${A}"
-       elog "    cd ${MY_P}"
-       elog "    find examples -name 'Makefile.*' -exec sed -i -e 's/-lm/-lm -lpthread/' '{}' \;"
-       elog "    ./configure"
-       elog "    cd examples"
-       elog "    make check"
-}