sys-libs/glibc: Do not check for IA32 abi when merging binary package
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Sat, 20 Jan 2018 18:12:20 +0000 (19:12 +0100)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Sat, 20 Jan 2018 18:13:09 +0000 (19:13 +0100)
Package-Manager: Portage-2.3.19, Repoman-2.3.6

sys-libs/glibc/glibc-9999.ebuild

index 224a4f232d08c92bee203f4879a713d8bfe41e7a..87549b89f6db0bac1059cc445cc0a01a53e9d119 100644 (file)
@@ -640,7 +640,7 @@ sanity_prechecks() {
        # we test for...
        if ! is_crosscompile ; then
 
-               if use amd64 && use multilib ; then
+               if use amd64 && use multilib && [[ ${MERGE_TYPE} != "binary" ]] ; then
                        ebegin "Checking that IA32 emulation is enabled in the running kernel"
                        echo 'int main(){return 0;}' > "${T}/check-ia32-emulation.c"
                        "${CC-${CHOST}-gcc}" ${CFLAGS_x86} "${T}/check-ia32-emulation.c" -o "${T}/check-ia32-emulation.elf32"