projects
/
gentoo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
6421d96
)
dev-libs/boost: Use python_gen_cond_dep on proper min numpy version
author
David Seifert
<soap@gentoo.org>
Sun, 15 Dec 2019 14:32:37 +0000
(15:32 +0100)
committer
David Seifert
<soap@gentoo.org>
Sun, 15 Dec 2019 14:32:37 +0000
(15:32 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-libs/boost/boost-1.72.0.ebuild
patch
|
blob
|
history
diff --git
a/dev-libs/boost/boost-1.72.0.ebuild
b/dev-libs/boost/boost-1.72.0.ebuild
index c03e60926c93f81557ea8912093af93108bac2b0..7434b5bd5d1604f05b58dfa4995f3ae5eb1b7ccc 100644
(file)
--- a/
dev-libs/boost/boost-1.72.0.ebuild
+++ b/
dev-libs/boost/boost-1.72.0.ebuild
@@
-39,7
+39,9
@@
RDEPEND="
mpi? ( >=virtual/mpi-2.0-r4[${MULTILIB_USEDEP},cxx,threads] )
python? (
${PYTHON_DEPS}
- numpy? ( >=dev-python/numpy-1.14.5[$(python_gen_usedep -3)] )
+ numpy? (
+ $(python_gen_cond_dep '>=dev-python/numpy-1.17[${PYTHON_USEDEP}]' -3)
+ )
)
zlib? ( sys-libs/zlib:=[${MULTILIB_USEDEP}] )
zstd? ( app-arch/zstd:=[${MULTILIB_USEDEP}] )"