Update revdep-rebuild to read config files from /etc/revdep-rebuild
authorfuzzyray <fuzzyray@gentoo.org>
Sun, 25 Sep 2005 15:37:19 +0000 (15:37 -0000)
committerfuzzyray <fuzzyray@gentoo.org>
Sun, 25 Sep 2005 15:37:19 +0000 (15:37 -0000)
svn path=/; revision=242

trunk/ChangeLog
trunk/src/revdep-rebuild/99revdep-rebuild [new file with mode: 0644]
trunk/src/revdep-rebuild/Makefile
trunk/src/revdep-rebuild/revdep-rebuild

index 52f7430bbbff541e7ba8fb9febbc7e52f99ed34b..9f857417352b488619785a670e48bc1b9e0fce46 100644 (file)
@@ -1,3 +1,7 @@
+2005-09-25 Paul Varner <fuzzyray@gentoo.org>
+       * revdep-rebuild: Update to read configuration files from
+       /etc/revdep-rebuild
+
 2005-09-23 Paul Varner <fuzzyray@gentoo.org>
        * equery: Sort output from equery list (bug 67152)
        * equery: Update man page (Bugs 73893, 74944)
diff --git a/trunk/src/revdep-rebuild/99revdep-rebuild b/trunk/src/revdep-rebuild/99revdep-rebuild
new file mode 100644 (file)
index 0000000..0a24337
--- /dev/null
@@ -0,0 +1,21 @@
+# Default revdep-rebuild configuration file
+#
+# revdep-rebuild no longer uses hardcoded paths. To change the default 
+# behavior the following variables can be changed:
+#
+# LD_LIBRARY_MASK - Mask of specially evaluated libraries
+#
+# SEARCH_DIRS - List of directories to search for executibles and libraries
+#      Use this for directories that are not included in PATH or ld.so.conf.
+#      An application should normally not have to set this variable
+#
+# SEARCH_DIRS_MASK - List of directories to not search
+#      Use this for directories that should not be searched by revdep-rebuild
+#      This is normally used by binary packages such as openoffice-bin
+#
+# Note: This file is sourced using bash by the revdep-rebuild script
+
+LD_LIBRARY_MASK="libodbcinst.so libodbc.so libjava.so libjvm.so"
+SEARCH_DIRS="/bin /sbin /usr/bin /usr/sbin /lib* /usr/lib*"
+SEARCH_DIRS_MASK=""
+
index 109b5aaef50d1b1b3c92cd30c53daab703febf36..934872f326f0ab66d14dc213e19be28052dba678 100644 (file)
@@ -11,7 +11,7 @@ all:
 
 dist:
        mkdir -p ../../$(distdir)/src/revdep-rebuild
-       cp  Makefile AUTHORS README TODO ChangeLog revdep-rebuild revdep-rebuild.1 find_pkgs.py ../../$(distdir)/src/revdep-rebuild/
+       cp  Makefile AUTHORS README TODO ChangeLog revdep-rebuild revdep-rebuild.1 find_pkgs.py 99revdep-rebuild ../../$(distdir)/src/revdep-rebuild/
 
 install:
 
@@ -21,3 +21,5 @@ install:
        install -d $(docdir)/revdep-rebuild     
        install -m 0644 AUTHORS README TODO $(docdir)/revdep-rebuild/
        install -m 0644 revdep-rebuild.1 $(mandir)/
+       install -d $(sysconfdir)/revdep-rebuild
+       install -m 0644 99revdep-rebuild $(sysconfdir)/revdep-rebuild/
index fbd7acb8be70cae5e3d329152b8e086b533b862d..6e36e1cc2cd3fd725adff12b70762cde6fede1c3 100755 (executable)
@@ -69,9 +69,19 @@ PRELIMINARY_SEARCH_DIRS_MASK="$SEARCH_DIRS_MASK $(portageq envvar SEARCH_DIRS_MA
 PRELIMINARY_LD_LIBRARY_MASK="$LD_LIBRARY_MASK $(portageq envvar LD_LIBRARY_MASK)"
 
 # Add the defaults
-PRELIMINARY_SEARCH_DIRS="$PRELIMINARY_SEARCH_DIRS /bin /sbin /usr/bin /usr/sbin /lib* /usr/lib*"
-PRELIMINARY_SEARCH_DIRS_MASK="$PRELIMINARY_SEARCH_DIRS_MASK /opt/OpenOffice"
-PRELIMINARY_LD_LIBRARY_MASK="$PRELIMINARY_LD_LIBRARY_MASK libodbcinst.so libodbc.so libjava.so libjvm.so"
+if [ -d /etc/revdep-rebuild ]
+then
+       for file in $(ls /etc/revdep-rebuild)
+       do
+               PRELIMINARY_SEARCH_DIRS="$PRELIMINARY_SEARCH_DIRS $(. /etc/revdep-rebuild/${file}; echo $SEARCH_DIRS)"
+               PRELIMINARY_SEARCH_DIRS_MASK="$PRELIMINARY_SEARCH_DIRS_MASK $(. /etc/revdep-rebuild/${file}; echo $SEARCH_DIRS_MASK)"
+               PRELIMINARY_LD_LIBRARY_MASK="$PRELIMINARY_LD_LIBRARY_MASK $(. /etc/revdep-rebuild/${file}; echo $LD_LIBRARY_MASK)"
+       done
+else
+       PRELIMINARY_SEARCH_DIRS="$PRELIMINARY_SEARCH_DIRS /bin /sbin /usr/bin /usr/sbin /lib* /usr/lib*"
+       PRELIMINARY_SEARCH_DIRS_MASK="$PRELIMINARY_SEARCH_DIRS_MASK /opt/OpenOffice /usr/lib/openoffice"
+       PRELIMINARY_LD_LIBRARY_MASK="$PRELIMINARY_LD_LIBRARY_MASK libodbcinst.so libodbc.so libjava.so libjvm.so"
+fi
 
 # Get the ROOTPATH and PATH from /etc/profile.env
 if [ -e "/etc/profile.env" ]