x11-wm/sawfish: Drop x11-libs/pangox-compat DEPEND, HOMEPAGE, https
authorAndreas Sturmlechner <asturm@gentoo.org>
Wed, 19 Feb 2020 21:33:06 +0000 (22:33 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 19 Feb 2020 21:33:58 +0000 (22:33 +0100)
Upstream commit 6d5640ecaa06948f3197b5d8cafb810cb3cf403c

Closes: https://bugs.gentoo.org/706342
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
x11-wm/sawfish/sawfish-1.12.0-r1.ebuild [new file with mode: 0644]

diff --git a/x11-wm/sawfish/sawfish-1.12.0-r1.ebuild b/x11-wm/sawfish/sawfish-1.12.0-r1.ebuild
new file mode 100644 (file)
index 0000000..06915f9
--- /dev/null
@@ -0,0 +1,87 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="${P/-/_}"
+inherit eutils elisp-common
+
+DESCRIPTION="Extensible window manager using a Lisp-based scripting language"
+HOMEPAGE="https://sawfish.fandom.com/wiki/Main_Page"
+SRC_URI="https://download.tuxfamily.org/sawfish/${MY_P}.tar.xz"
+
+LICENSE="GPL-2 Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ia64 ppc ~ppc64 ~sh sparc x86"
+IUSE="emacs kde nls xinerama"
+
+RDEPEND="
+       emacs? ( >=app-editors/emacs-23.1:* )
+       >=dev-libs/librep-0.92.1
+       >=x11-libs/rep-gtk-0.90.7
+       x11-libs/gdk-pixbuf:2[X]
+       >=x11-libs/gtk+-2.24.0:2
+       x11-libs/libXtst
+       kde? ( kde-frameworks/kdelibs4support )
+       nls? ( sys-devel/gettext )
+       xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+       # From Fedora
+       "${FILESDIR}"/${P}-desktop.patch
+)
+
+DOCS=( AUTHORS ChangeLog CONTRIBUTING doc/AUTOSTART doc/KEYBINDINGS doc/OPTIONS doc/XSettings MAINTAINERS NEWS README README.IMPORTANT TODO )
+
+src_configure() {
+       set -- \
+               $(use_with kde kde5session) \
+               $(use_with xinerama) \
+               --with-gdk-pixbuf \
+               --without-kde4session \
+               --disable-static
+
+       if ! use nls; then
+               # Use a space because configure script reads --enable-linguas=""
+               # as "install everything". Don't use --disable-linguas, because
+               # that means --enable-linguas="no", which means "install
+               # Norwegian translations".
+               set -- "$@" --enable-linguas=" "
+       elif [[ "${LINGUAS+set}" == "set" ]]; then
+               strip-linguas -i po
+               set -- "$@" --enable-linguas=" ${LINGUAS} "
+       else
+               set -- "$@" --enable-linguas=""
+       fi
+
+       econf "$@"
+}
+
+src_compile() {
+       default
+       use emacs && elisp-compile sawfish.el
+}
+
+src_install() {
+       default
+       find "${D}" -name '*.la' -delete || die
+
+       if use emacs; then
+               elisp-install ${PN} sawfish.{el,elc}
+               elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el
+       fi
+}
+
+pkg_postinst() {
+       use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+       use emacs && elisp-site-regen
+}