app-emulation/vagrant: revbump, fix ruby_dep dep
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Fri, 13 Mar 2020 05:42:24 +0000 (22:42 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Fri, 13 Mar 2020 05:42:24 +0000 (22:42 -0700)
Closes: https://github.com/gentoo/gentoo/pull/14938
Closes: https://bugs.gentoo.org/711576
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
app-emulation/vagrant/vagrant-2.2.7-r1.ebuild [moved from app-emulation/vagrant/vagrant-2.2.7.ebuild with 94% similarity]

similarity index 94%
rename from app-emulation/vagrant/vagrant-2.2.7.ebuild
rename to app-emulation/vagrant/vagrant-2.2.7-r1.ebuild
index d81979d0d04a67a06ef0323378d64b5096a4f208..19daab60aa2dca8aa0460a70b695d1142b99dc4d 100644 (file)
@@ -59,7 +59,6 @@ all_ruby_prepare() {
 
        # loosen dependencies
        sed -e '/hashicorp-checkpoint\|i18n\|listen\|net-ssh\|net-scp\|rake\|childprocess/s/~>/>=/' \
-               -e '/ruby_dep/s/<=/>=/' \
                -i ${PN}.gemspec || die
 
        # remove windows-specific gems
@@ -70,6 +69,10 @@ all_ruby_prepare() {
        sed -e '/rb-kqueue/d' \
                -i ${PN}.gemspec || die
 
+       # remove ruby_dep, it's unused and only listed to loosen ruby implementation deps
+       sed -e '/ruby_dep/d' \
+               -i ${PN}.gemspec || die
+
        sed -e "s/@VAGRANT_VERSION@/${PV}/g" "${FILESDIR}/${PN}.in" > "${PN}" || die
 }